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Introduction to TopSolid 

In this first section, you will discover and understand how TopSolid works and the main methods for using the 
software. 

General workspace 

Home page 

When TopSolid'Wood starts, a home page lets you access many features. 

 

The home page consists of three main parts: 

 News feeds on the right: 

The bottom thumbnail gives you access to the TopSolid newsletter, the middle thumbnail shows the latest 
version's new features and the top thumbnail displays hints. 

 Recent documents in the middle: 

The last opened documents are displayed as thumbnails in the middle of the screen. At the bottom of this area, 
the Explore button lets you open Windows Explorer. 

Several functions can be called up from these thumbnails: 

- Double-click on a thumbnail: Open the document. 
- Ctrl + Mouse wheel: Adjust the size of thumbnails. 
- Right-click > Empty: Clear the list of thumbnails. 
- Right-click on a thumbnail > 

o Open: Open the document. 
o Remove: Remove the document from the list. 
o Open directory: Open the Windows directory of the document. 

o Pin to the list/Unpin from the list:  Keep or not the document at the top of the list. 
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 Creation of new documents on the left: 

At the top you can select the type of document you want to create 
(for example TopSolid Design, Draft or WoodCam). 
 
Note: The last document template used is displayed next to the 
selected document type. 
You can then create a new document from the last template used by 
double-clicking on the type of document you want. 
 
Once you have selected the document type to be created, the available 
document templates are displayed in the lower half of the window and 
are listed by category: User templates (local user templates), Group 
templates (templates common to the working group) or Standard 
templates (templates that come with TopSolid). 
 
Note: You can adjust the size of the template's thumbnails using Ctrl + 
Mouse wheel. 
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Working environment 

TopSolid'Wood's user interface is made up of several areas that give you quick and easy access to the functions 
you need. 

 

Note: The contents and the layout of menus, contexts and icons can be customized using styles. 
The style used for documentation is the default style selected in Tools > Configure styles > Style > Default. 
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The menu bar 

Use the menu bar to navigate between the various menus and sub-menus available. 

The system bar 

The system bar contains the basic functions of TopSolid. These icons are identical whatever the context. 
 

 New document: Create a new document. 

 Open document: Open TopSolid files and all available formats. 

 Save/Save as/Save all: Save the current file or all open files. 

 Cancel: Cancel the current function. 

 Undo: Undo the last action of the current function. 

 Delete: Delete an item. 

 Edit: Make changes to an item. 

 View tab: Access the settings of the 3D document's view (top view, perspective view…). 

 Rendering tab: Select the rendering mode. 

- Wireframe: Show the edges. 
- Shading: Show the design colors. 
- Realistic: Show the part textures. 

 : Make invisible/Make visible an item of the design project. 

The context bar 

The context bar (opposite) is used to select the icons to be displayed in the function bar. 

The function bar 

The function bar contains the icons of the context selected in the context bar. 
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The tab bar 

 

The tab bar displays open documents and the start page. 
Each type of document is displayed with a specific icon and color. 

 Left-clicking on a tab makes the selected document current to work. 

 Click-and-dragging: 

- in the tab bar allows you to move and rearrange the tabs.  
- on a side of the graphics area creates a group of documents. 

  

 Double-clicking on a tab lets you return to a single tab group by making the selected document current. 

 You can close the document by clicking the red cross 
icon displayed in the opened tab or by clicking and 
scrolling the mouse wheel. 

 Various options are also available by right-clicking on a tab: 

- Open Windows directory 
- Save 
- Close all but this 
- New vertical tab group 
- Group by document type 

 If there are several tab groups, you can also: 

- Resize the groups using the cursor between the groups. 
For vertical tab groups, the double-arrow cursor in the tab bar enables you to resize the groups. 

 

 

- Readjust the dimensions of the groups by right-clicking > Balance the groups. 
- Maximize the size of a group by right-clicking > Maximize. 

This option allows you to maximize the size of a group in order to work without closing the configured 
groups. 

 Ctrl + Tab scrolls through the open documents contained in the same group. 
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 The state of the document is also displayed in the tab to the right of the document name: 

- Modified and unsaved document: * 
- Document containing one or more invalidities: ? 
- Document containing one or more elements in insertion: ! 

 

Note: Invalid elements or elements in insertion can be found from the construction tree: right-click > Edit sets > 
Invalid elements set or Elements in insertion set. 

 A black tab is displayed to the right of each graphics group's tab bar. 
It lists the documents opened in the tab group and allows you to make the selected document current. 
This is useful when a number of documents are open. 

 

 When you hover your mouse over a tab, a text is displayed with the type of document and the full path of the 
file. 

 

The status bar 

The status bar allows you to set the working parameters. 
These settings are divided into categories: 

- Screen: Set the items displayed in the graphics area. 
- Miscellaneous: Set specific functions or the working 

environment. 
- Attributes: Set parameters for the new created items. 
- Planner: TopSolid'Planner settings. 

 
Each line displays a setting with the name in the left cell and the 
setting value in the right cell. 
 
Additional information on the setting is displayed in the lower portion 
of the status bar. 
  



TopSolid'Wood Basics  Introduction to TopSolid 

Missler Software   7 

The alpha bar 

 

Unlike the dialog bar, the alpha bar is used to provide information to the user. 
It sends explanations to the user or errors in the current function. 
These messages are divided into three categories: Messages, Named parameters, Measures. 

It is possible to: 

 type and copy/paste text in the Named parameters and Measures tabs 

 change the number of displayed lines by resizing the bar height 

 empty the contents of the alpha bar by right-clicking > Empty. 
 
Note: The alpha and status bars can be moved on the screen. 

 These bars are displayed as tabs that fold automatically when the mouse cursor is out of the tab. 
 
 
 
 
 
 
 
 
 
 
 

 You can pin these bars in order to keep them visible on the screen.  

 You can close these bars by clicking the red cross icon.  

 Once the bar is pinned, you can move it by click-and-dragging on the header: 

- On the screen where TopSolid is or on another screen of the computer 
- On one side of the TopSolid window automatically using the arrows that appear. 

 
 
 
 
 
 

 These bars can also be resized using the cursors on the window 
frame. 

 
 
 

 If any item of the working area is missing, you can reopen it using the Window menu. It is then possible to 
reopen the start page, the status bar or the alpha bar. 
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The construction tree 

The construction tree lets you edit the project components, see how they were built and display the lists of items 
of the file. 

 The construction tree can be opened by left-clicking the double-arrow 
cursor on the left edge of the graphics area. 

 
 

 By default, the construction tree consists of five tabs: 

- Main: Display the item being edited. 
- Favorite: Insert favorite components. 
- Main set: Display the items defined in the project's main set. 
- Entities: List the project components such as shapes, sketches, parameters and coordinate systems. 
- Layers: Manage the document's layers. 

 
 
 
 
 
 
 
 
 
 

 
 

 

 You can also add additional tabs by right-clicking in the tree: 

- Append presentations: Display the document presentations. 
- Append links: Display the links and updates of the elements included in the document. 
- Append index: Create new indexes. 
- Import indexes: Import the indexes created in another document. 
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Control features 

The icons 

The system and function bars use two types of icons: 

 Simple icons: Execute a function when they are clicked. 

 New File simple icon 
 

 Drop-down icons: Execute a function when they are clicked and also propose other associated functions 
when the black icon is clicked or by right-clicking on the icon. 

 List icon for printing 
 
 

Click on the black icon to open a list of associated functions. 
 
 
 

Note: Once the function has been selected in the list, it becomes the main function. 

The dialog bar 

 

The dialog bar is activated when the user starts a function. 
It is used for communications from the user to the software and is read from left to right. 
 
There are four types of dialog buttons: 

 Rotary buttons: Used to switch from one status to another, while staying in the same dialog. 

  

 Confirmation buttons: Used to confirm the dialog and to progress to the next dialog or open a subdialog. 

   

 Data entry buttons: Used to enter a value or to select a graphical item. 

  

 Drop-down buttons: Used to select a value in the proposed list. 
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The compass 

The different parts of the compass are used to navigate in the graphics area. 

 Rotation around a point: Rotate around a point by clicking and dragging one of the arrows. 

 

 Rotation around an axis: Rotate around an axis by clicking and dragging one of the quarter circles. 

 

 Moving the compass: Click and drag on the center of the compass to move it. 

 

 Set the orientation of the view along an axis: Left-click on an axis to orientate the view according to this axis. 

 

 Move the view: Click and drag on an axis of the compass to move the view. 

 

The scale and the laser distance meter 

 A scale at the bottom right of the graphics area indicates the size order of the items displayed in the 3D space. 
 
 

 
 
Note: The scale is not displayed in conic perspective view. 
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 Left-click and dragging the scale enables you to use the laser distance meter: 

- In the first step a sphere is hooked to the mouse cursor. 
 
 

- Then you need to drag this sphere to a flat surface to do laser measuring. 
The measure is made from the original flat face to the first detected parallel face. 

 

- If no parallel face is found, no measure is performed, but the laser distance meter is still positioned on the 
face. 
You can then click and drag the second disk of the laser distance meter to carry out the measure 
to another face. 

 

- Once the measure is carried out, you can right-click on the laser distance 
meter to: 

o create the 3D dimension of the measure 
o create the parameter of the measured distance 
o create a coordinate system (coordinate system on face with 

constraints where the laser distance meter is positioned) 
 

- The laser distance meter can then be hidden by right-clicking > Unhook on the meter or by left-clicking on 
the scale. 

  



Introduction to TopSolid  TopSolid'Wood Basics 

12   Missler Software 

Using the mouse 

 Left-click: Select an item. 

 Thumbwheel: Zoom in and out in the graphics area. 

 Click-and-drag plus thumbwheel: Move the view. 

 Right-click: Validate the first button on the left of the dialog bar. 

Keyboard shortcuts 

 Ctrl + left-click and drag: Rotate around a point (center of the screen). 

 Shift + left-click and drag: Move the view. 

 Esc: Exit the current function. 

 F1: Open the online help for the current function. 

 F2: Start the item analysis function in order to obtain information about an item in the graphics area. 

Note: Keyboard shortcuts can be customized in Tools > Options > Shortcut key. 
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Exercise 1: 2D sketch 

The goal of this exercise is to make the component parts of the lamp. 

Concepts addressed: 

- Creating a sketch 
- Dimensioning a sketch 
- Constraining a sketch 
- Extruding a part 
- Turning a part 

 

Lamp support 

The 2D sketch is used to draw a part in 2D in order to then produce the 3D. 
 

Create a new document 

 Create a new document.  

 Select a Design document type. 
In the Advanced parameters, select Without template. 

 

 

 

 Select the Associative design mode and then Millimeters. 

 

 Click on OK to confirm. 

 In the context bar, activate the Sketch context.  

 Start a new sketch from the function bar.  

 Select Current coordinate system as the reference coordinate system.  
 
Note: A green frame appears around the work area when the 
sketch mode is active. 

 Create a four-segment contour around the absolute 

coordinate system.   

 Select one of the segments to close the contour. 
 
The sketch turns orange once the contour is finished. 
This means that no constraints have been applied yet. 
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Create a sketch 

 Delete the segment of the sketch [2;3].  

 Start the Circle function.  

 Set a 400mm diameter in the dialog bar. 

 
 

 Then select points (2) and (3) in Passing point mode. 

 If the arc of the circle is positioned on the wrong side, select 
Invert in the dialog bar to invert it. 

Constrain the sketch 

 Start the Constraint function.  

 Use the Perpendicularity constraint.  
Apply the constraint between the segments [1;2] and [1;4], 
and then between the segments [1;4] and [3;4]. 

 Use the Orientation constraint.  
Apply the constraint to segment [1;4] and select Along X in 
the dialog bar. 

 
 
 
Note: The constraints are represented by green symbols on the sketch.  
Delete this symbol in order to remove the constraint. 

- Perpendicularity constraint:  

- Orientation constraint on the X axis:  
 

Dimension the sketch 

 Start the Dimension function.  

 Select segment [1;2], position the dimension and set the 
nominal value to 150mm in the dialog bar. 

  
 

 Repeat the same operation for segment [3;4] with 
150mm, and for segment [4;1] with 200mm. 
 

 Use Modify parameter to change the value of a 

dimension.  

 Select the dimension positioned on segment [4;1] and 
change its nominal value to 250mm. 
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Make fillets 

 Start the Fillet function.  

 Select Mode: Global. 

 Enter a fillet radius of 10mm, then select the four corners 
of the contour in Curve to modify. 

 
 
Note: The fillet previews are shown in red. 
 
 
 
 

 Create the fillets by selecting Compute fillet(s) in the dialog bar. 
 

Dimension the sketch on the absolute coordinate system 

 Start the Dimension function.  

 Select segment [1;4], then the X axis of the absolute 
coordinate system. Enter a nominal value of 100mm. 

 Then dimension the segment [1;2] with the Y axis of the 
absolute coordinate system with a value of 125mm. 

 
Note: Once one or more segments are totally constrained, 
they turn green. 
 
 
 

 Finish the sketch with the End sketch function.  

 In the context bar, activate the Shapes context.  

 Start the Create extruded shape function.  

 Select the 2D sketch created previously, enter a 
height of 5mm in the dialog bar, then press Enter 
to confirm. 

 
 
 
 

 Save the file by clicking on the disk icon.  

 Answer No to the request for a part definition. This point will be covered later on. 

 Create a new folder called Lamp and rename the file Base. 
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Light shade 

Create new document 

 Create a new document. 

 Select a Design type document. In the Advanced parameters, select Without template. 

 Click on OK to confirm. 

 In the context bar, activate the Sketch context.  

 Start a new sketch from the function bar.  

 Select Current coordinate system as the reference coordinate system.  

Build a line 

 Start the Line function.  

 Draw a line as shown opposite. 

 Start the Constraint function.  

 Use the Alignment constraint.  

 Click on the point (1), then the X axis of the absolute coordinate system. 

 Click on Stop in the dialog bar. 
 

 Start the Dimension function.  

 Click on the point (1), then the Y axis of the absolute coordinate 
system. Position the dimension and enter a nominal value of 
150mm. 

 Then click on the segment [1;2], position the dimension and 
enter a nominal value of 145mm. 

 Click on the segment [1;2], then on the X axis of the absolute 
coordinate system to create an angle dimension. Position the 
dimension and enter a value of 60°. 

 
 

Create a circle arc 

 Start the Circle function. 

 Enter a radius of 50mm. 

 In the Passing point mode, select the point (2), then a second point 
on its right. 

 
 

 If the arc of the circle is positioned on the wrong side, click on Invert 
in the dialog bar. 

 
 
Note: If the segments are drawn using the Contour function, it is possible to directly draw a tangent arc with the 
Link = Tangent function using the keyboard shortcut A. 
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Constrain the circle arc 

 Start the Constraint function.  

 Use the Tangency constraint.  
Select the segment [1;2], then the circle arc [2;3]. 
These two entities are now tangential. 

 

 Start the Dimension  function and dimension the point (3) 
relative to the X axis at a distance of 150mm. 

 
 

Create an offset 

 Start the Offset function. 

 Set the Offset type = Profile option, then select the sketch 
already drawn. 

 
 Change to Mode = One side, position the mouse cursor inside 

the sketch to choose the offset side, and then enter a value of 
5mm. 

 

 Press Enter to confirm. 

 Position the distance dimension of the offset. 
 

Note: If the offset is on the outside, use Modify parameter  to change the nominal value of the dimension to 
-5mm. 

 

Close the contour 

 To close the contour, create two lines to close the sketch with the Line  
function between points 1 and 1', then between points 3 and 3'. 

  

 Start the Constraint function.  

 Apply an orientation constraint  to the segment [1;1'] along 
X. 

 Apply an orientation constraint to the segment [3;3'] along Y. 

 

 
Note: All segments of the sketch are green, which means that the 
sketch is totally constrained. 

 Finish the sketch with the End sketch function.  
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Turn the part 

 In the context bar, activate the Shapes context.  

 Start the Create turned shape function.  

 In the dialog bar, set Type = Solid and Generatrix sketch = Global. 

 Select the previously created sketch in the Section curves or texts field. 

 

 In the dialog bar, select the Y+ axis as the axis of revolution to generate the part around this axis. 

 
 In the dialog bar, set Alignment = Normal, Generatrix = 

Hidden and Angle = 360°. Finish by clicking on OK to confirm. 
 
 

 

 Save the file by clicking on the disk icon. 

 Answer No to the part definition window. 

 Save the file in the Lamp folder and rename it Light shade. 

Body of the lamp 

Create a new document 

 Create a new document of the Design type. In the Advanced parameters, select Without template. 

 Click on OK. 

 In the context bar, activate the Sketch context.  

 Start a new sketch from the function bar.  

 Select Current coordinate system as the reference coordinate system.  

Draw a line 

 Start the Line function.  

 Click on the first point in the line under the absolute 
coordinate system. 

 In the dialog bar, set Axes (Z) = YES. 

 

Note: This function is used to automatically draw lines parallel 
to the X and Y axes. 
Consequently, the lines are automatically constrained by 
orientation along X or along Y. 

Note: This function can be quickly switched on and off by 
pressing Z on the keyboard. 

 Click on a second point to the right of the first one. 
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Dimension the line 

 Start the Dimension function and dimension the segment [1;2]. 

 In the dialog bar of the dimension, enter a nominal value of 150mm. 

 
 

 Then activate the Symmetry constraint option and select Y. 

  
 

Note: Inserting a symmetry constraint on the Y axis centers the 
dimension in relation to the Y axis, irrespective of its length. 
 
Note: When the dimension is constrained on an axis, it is displayed 
between two ‘=’ signs. 

 

 Dimension the segment [1;2] in relation to the X axis with a value of 150mm. 
 

Build a second line 

 Repeat the same operations to produce the segment [3;4] shown 
opposite. 

 Draw the line [3;4] with Axes (Z) = YES.  

 Dimension this segment with a nominal value of 100mm.  

 Apply a symmetry constraint on Y to the dimension. 

 
 Dimension the segment [3;4] relative to the segment [1;2] with a 

nominal value of 300mm.  
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Draw the circle arcs 

 Start the Circle function.  

 Enter a radius of 200mm and select point (1) in Passing point mode, 
then any point between point (1) and point (3). 

 

 
 

 Click on Invert to invert the side of the arc. 
 

 
 

 Without leaving the function, select point (5) created previously, then 
point (3). 

 

 Then apply a tangency  constraint  between the arcs (1;5) 
and (5;3). 

 

 
 

 Repeat the same operations to produce the drawing shown opposite. 
 

 Start the Circle function.  

 Enter a radius of 200mm and select point (2) in Passing point mode, 
then any point between point (2) and point (4). 

 Without leaving the function, select point (6) created previously, then 
point (4). 

 Click on Invert to invert the side of the arc. 
 

 Then apply a tangency  constraint  between the arcs (2;6) 
and (6;4). 

 

Constrain and dimension the points 

 Start the Constraint function.  

 Use the alignment constraint, then select the points (5) and (6).  
 

 Then click on Stop and select Alignment along X. 

  

 

 Use the Dimension function to dimension the distance between the 
points (5) and (6) at a nominal value of 150mm. 
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Create an offset profile 

 Start the Create offset profile function.  

 Set Offset type = Profile, then select the Reference curve option and 
select the sketch. 

 
 

 Set Mode = One side. 

 Place the offset inside the sketch, then enter a value of 30mm in 
Through point and press Enter. 

 

 Finish positioning the dimension. 
 

Create fillets 

 Start the Fillet function.  

 Enter Fillet radius: 10mm, then select the four corners of the offset 
created previously. 

 
 

 Create the fillets with the Compute fillet(s) option. 

 
 
 
 
 
 
 

Extrude the sketch 

 Finish the sketch with the End sketch function.  

 In the context bar, activate the Shapes context.  

 Start the Create extruded shape function.  

 Set the Generatrix sketch = Global and Result = One shape modes. 

 
 

 Select the 2D sketch created previously, enter a height of 30mm in the dialog 
bar, then press Enter to confirm. 

 

 Save the file by clicking on the disk icon.  

 Answer No to the part definition window. 

 Save the file in the Lamp folder and rename it Body.  
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Exercise 2: Creation of a bed side panel 

In this exercise, we are going to make the left-hand side panel of the bed. 

Concepts addressed: 

- Creating arc blends in a sketch 
 

Design of the side panel 

Create a new document 

 Create a new document of the Design type. In the Advanced parameters, select Without template. 

 Click on OK to confirm. 

 In the context bar, activate the Sketch context. 

 Start a new sketch. 

 Select Current coordinate system as the reference coordinate system.  

Draw the lines 

 Draw the seven lines below with the dimensions shown.  

- All the lines are oriented along the X or Y axes. 
- Lines 7 and 1 start from the absolute coordinate system. 
- Line 5 is aligned with the X axis of the absolute coordinate system. 

 

 Create fillets with a radius of 50mm between segments 1/2, 3/4, 4/5 and 7/1. 
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Create the arc blends 

 Start the Arc blend function.  
 
Note: The Arc blend function is used to automatically 
create two tangent arcs between two points and in two 
directions. 
 
 
 
 

 Select the right-hand extremity of segment 3 as the first point and X+ as the first direction. 

  
 

 Select the left-hand extremity of segment 2 as the second point and X- as the second direction. 

  
 

 

 Repeat the operation to create the arc blends between segments 5 and 6 and between segments 6 and 7. 
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Extrude the part 

 Finish the sketch with the End sketch function.  

 In the context bar, activate the Shapes context.  

 Start the Create extruded shape function.  

 Select the 2D sketch created previously and enter a height of 22mm in the dialog bar. 

 

 Save the file by clicking on the disk icon.  

 Rename the file Bed side panel. 

 

Supplement: Machining the decorative grooves 

Create a groove 

 In the context bar, activate the Wood context.  

 Start the Groove function.  

 Select Sweep = Planar face and select the main face of the side panel as the reference face. 

 
 

 

 In the dialog bar, set Join edges = YES and Follow tangent edges = YES. 

 
 
Note : The Join edges = YES option is used to create a single machining operation for all the selected edges. 
The Follow tangent edges = YES option is used to automatically select all the tangent edges of the selected edge. 
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 In the Reference edge or curve for tool path option, select one of the edges of the selected face. 
Since all the edges of the face are tangential, they are all selected in one go. 

 

 Click Stop to validate the edges. 

Note: Two red arrows appear. The small arrow represent the direction of the machining and the large 
perpendicular arrow indicates the gap side of the groove. 

 The gap must be towards the inside of the part. If this is not the case, click on the arrow to invert. 

 

 Once set, click on OK to confirm. 

Configure the groove 

The groove settings window opens. 

 Configure the various points mentioned below, from the top to the bottom of the window. 

 Select a Routers type tool.  

 In the list, select Simple mill. 
 
 

 In Parameters, enable the High arm option. 

 Enter the following parameters: 

- Gap distance = 50mm 
- Groove width = 10mm 
- Groove depth = 5mm 
- Angle = 0° 

 

 Click OK to validate the settings of the groove. 
 

 

 Save and close the file.  
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Exercise 3: Creation of a shelf 

The goal of this exercise is to make the parts of the shelf. 
 
 
 
 
 
 
 

Making the base  

Concepts addressed: 

- Creating points 
- Dimensioning points 
- Extrusion in one direction 

Create a new document 

 Create a new document of the Design type. 

 In the context bar, activate the Sketch context. 

 Start a new sketch in the function bar. 

 Select Current coordinate system as the reference coordinate system. 

Draw the top lines 

 Start the Contour function.  

Note: The Contour function is used to draw a series of segments or arcs. 
The Link drop-down list can be used to choose the type of segment when drawing: Line, Intersection, Arc, 
Tangent arc,etc. 
 

 Select the origin of the absolute coordinate system as the profile or starting point. 

 In the drop-down list, select Link = AXES (Z) to automatically orientate the segment along X or Y. 

 

 Draw the three segments as shown below. 

 For segment [2], set Link = Line in the drop-down list.  

 

 Use the Dimension function to apply the length and angle dimensions as shown above.  
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Draw the low lines 

 Using the Contour function, draw the three other segments [4], [5] and [6] as shown below, with Link = Axes 

(Z).  

 Dimension the three lengths of these segments.  

 Dimension the distance between segment [3] and segment [6]. 

 Use the Constraint  function to apply an alignment constraint  between the right-hand point of the 
segment [4] and the left-hand point of the segment [3]. 

 Click Stop and align along Y. 
 

 

Draw the left-hand part 

 Draw a line from the origin of the absolute coordinate system as shown below.  

 

 Dimension the left-hand point of the line. 
 
Note: The dimension of a point is made up of two dimensions on X and on Y from 
the current coordinate system. The horizontal dimension is the dimension along Y 
and the vertical dimension is along X. It is only possible to delete one of them. 
 
 

 Use the Modify parameter  function to change the value of this point to -70mm along X and 70mm along 
Y. 

 Finish by drawing a circle with a radius = 250mm from the point previously created to the left-hand extremity 
of segment [4]. 
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Draw the right-hand part 

 Then draw a line between the right-hand point of the segment [6] as shown below.  

 Dimension the right-hand point of this line relative to the right-hand point of the segment [6].  

 Apply a value of 60mm along the X axis and 50mm along the Y axis. 

 Draw a circle with a radius = 250mm passing through the point created previously and through the right-hand 

point of the segment [3].  

 

Extrude the part 

 Finish the sketch.  

 Activate the Shapes  context in the context bar and start the Create extruded shape function. 

 Select the 2D sketch created previously, click on Direction and select Z+. 

This setting is used to adjust the direction of extrusion of the part. 

 Enter a height of 30mm, then press Enter to confirm. 

 

 Save the file by clicking on the disk icon.  

 Create a new folder called Shelf and rename the file Shelf. 
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Making the sides 

Concepts addressed: 

- Using layers 
- Copying edges 
- Using profiles 
 
 
 

Use the layers 

Note: Layers are used to position items on them and to display and conceal them in the course of the design 
operations. 
This reduces the number of items in the graphics area and improves the organization of the design. 

 
Layers can be managed using the Quick layers bar. 

 
 

Note: If the Quick layers bar does not appear on the screen, use Window > Quick layers 
to display it. 

 
 

 Set layer 1 as current by clicking on 1 with the thumbwheel. All newly created items will now belong to 
layer 1. 

Note: The current layer is shown in green in the Quick layers bar.  

Copy the edge of the base 

 Start the Curves context.  

 Use the Edge function.  

Note: The Edge function is used to automatically create several curves from parts such as faces, shapes or edge 
contours. 

 Use Mode = Face contour to copy all the edges of a face. 

 

 In the Face to get the boundary contour from field, enter the rear face (Z-) of the base. 

 

A contour made up of several curves is automatically created around the face. 
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Create thickened curves 

 Left-click 0 in the layers bar to switch off layer 0. 

 

Note: Switching off a layer conceals all the items that belong to that layer. In this case, it is the base part and the 
absolute coordinate system. 

 Use the Thickened curve function in the Curves > Thickened curve menu. 

 

Note: Thickened curves are used to automatically create closed contours from a segment or a contour. 

 

  

 

Thickened curve of a segment at the end External arcs 

 

  

 

Thickened curve of a segment at the end Mitre cut 
 

 Enter Thickness = 10mm, Symmetric = No, Second thickness = 0mm, then End type = Mitre cut. 

 
 

In the Reference curve option, select a segment of the contour and not the whole contour. To do this, use the 
rotary selection. 

Note: Rotary selection is used to select several elements that are superimposed. This is the case here, where the 
contour and the different segments are superimposed. 

 Place the mouse cursor on a segment of the 
contour, then left-click and hold. Then 
right-click to go from one part to another. 

 
 
 
 
 
 

 Release the left-hand mouse button when the cursor passes over a segment of the contour, as shown above. 

 Use the All segments option to automatically create thickened curves of the entire contour.  
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 Place the thickened curves outside the 
contour with the red arrow, as shown below. 

 

 Click OK to validate the thickened curves. 
 
 
 

Extrude the sides 

 Start the Shapes context.  

 Start the Create extruded shape function.  

 Select a first thickened curve. 

 Extrude in the Z+ direction  to a height of 250mm.  

 Repeat the operation to extrude the ten sides. 

Note: When you extrude an element, you can click on another extruded element in order to extrude it to the 
same height. 

 Left-click on 0 in the layers bar to switch on layer 0. 

 

Supplement: Configuring the length of the shelf 

 
 
 
 
 
 
 
 

Create the parameter 

 To create a parameter, start the Create function in the Parameter menu. 

 

 Select Unit type = Length and enter a value of 600mm. Press Enter to confirm. 

 
  

Note 
 
A parameter is used to check and quickly 
modify the value of one or more design values. 
This parameter can be a length or angle 
parameter, or a parameter without units used 
to configure a quantity. 
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 Enter Name = l and Designation = Length. Press Enter to confirm. 

 
 
Note: The name is the system name of the parameter that will be used in the various dimensions. The 
designation is what the user sees when using the parameter. 

 Click on the No text option.  

Note : This dialog is used to graphically display the parameter on the screen. 

 Press Esc to exit the function. 

Display the sketch 

 Start the Driving elements function.  

Note: Once a drawing element has been used (e.g., when a sketch is used to extrude a part), it is automatically 
hidden. Use the Driving elements function to display the elements used by another element. 

 Select the base of the shelf that was extruded earlier. The sketch used to build the base is displayed 
automatically. 

 

 

Include the parameter in the sketch  

 Start the Parameter > Modify parameter function. 

 Then click on the 600mm length in the bottom left-hand corner. 

 In the dialog bar, select Parameter , then Replace.  

 Select Replacement = Local and enter Replacement parameter = l. 

  
 

 Press Enter to confirm. 

The value is now controlled by the parameter l. 
 

 Repeat the same operations for the 600mm value in the bottom right-hand corner. 

 Then replace the two upper dimensions of 500mm with the Replacement parameter = l-100. The dimension 
then has the same value as the parameter l-100mm. 

 
 
The four length values of the shelf are now configured. 
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Use the parameter 

 Start the Driving elements function.  
Select the base to hide the sketch used to build it. 

 Start the Modify parameter function in the Parameter menu. 

 
 

 Enter Parameter to modify = l, and press Enter to confirm. 

 
 

Note: When entering a parameter in a field, the field turns yellow if the parameter entered already exists. 

 Change the nominal value to 700mm, and press Enter to confirm. 

The length of the shelf is automatically adjusted according to the parameter. 
Any lengths greater than 200mm can be entered. 
 
 
 

- For l=700mm: 
 
 
 
 
 

 

- For l=200mm: 
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Exercise 4: Creation of an indoor bench seat 

The goal of this exercise is to create the parts and 
then understand how definition of parts and 
whole assembly works. 
 
 
 
 

Making the base 

Draw the base 

 Create a new document of the Design type.  In the Advanced parameters, select Without template, then 
click OK to confirm. 

 In the context bar, activate the Sketch context, then start a new sketch.  

 Select Current coordinate system as the reference coordinate system. 

 Use the Create contour function.  

 Select the Rectangular option in the dialog bar.  

 Set constraints = orientation and select any two points as the first and second points on the diagonal. 
 

 To finish, click on Auto dimension  
to automatically apply the dimensions. Press Esc 
to exit the function. 

 Use Modify parameter  to change the 
nominal value of the dimension on X to 600mm, 
then the dimension on Y to 400mm. 

 

 Use Modify element , then select the 
dimension of 600mm. Select Constraint, then Y to 
symmetrically constrain the dimension along the Y 
axis. 
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Position the base 

 Use the Constraint  function and 

align  the lower segment along the X axis 
of the absolute coordinate system. 

 Set the Offset  Offset type = Profile to draw 
the offset inside the rectangle at a distance of 
15mm. 

 Finish the sketch with the End sketch function. 

 
 

Extrude the base 

 Start the Shapes  context, then use the Create extruded shape function.  

 Select the sketch created earlier in Generatrix sketch = Global and Result = One shape modes. 

 

 
 

 Open the advanced parameters  and enter an offset from 
starting curve of 500mm, then click OK to confirm. 

 

Note: The offset distance offsets the starting point of the 
extrusion relative to the drawing plane of the sketch. 

 
 
 
 
 

 Use the Direction option to impose an extrusion direction towards Z+. 

 Enter a height of 80mm, then press Enter to confirm. 

 Save the document and rename it Indoor bench seat.  
 

Repeat the base 

 Start the Edit > Repeat function. 
 
Note: The Repeat function is used to produce the same part several times from a 
template. The parts created are identical. 
 

 Select the previously extruded part in Hide template = Yes mode. 

 

Note: The selected part(s) to be repeated turn red. 
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 Select the Simple mirror type of repetition using 
the button. 

 

 Select the plane XY as the plane of symmetry.  
 

Creating the seat 

Draw the seat 

 Make level 1 current. 

 Start a new sketch.  

 Select Current coordinate system.   

 Use the Create contour function.  

 Select the Rectangular  option, then draw a rectangle. 
 
 

 Use the Constraint  function to put a coincidence  constraint 
between the left-hand side of the drawn rectangle and the interior left-
hand segment of the base. 

 Repeat the operation between the right-hand side of the drawn 
rectangle and the right-hand interior segment of the base. 

 
 

 Then apply a coincidence constraint between the top segment of the 
drawn rectangle and the top exterior segment of the base. 

 

 Use Dimension to set the height of the rectangle to a nominal value of 
50mm. 
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Extrude the seat 

 Finish the sketch with the End sketch function.  

 Start the Shapes  context, then use the Create extruded shape function.  

 Select the sketch drawn earlier. 

 Use Alignment = Centered . Enter a height of 1500mm.  

Note: Extruding a shape in Alignment = Centered mode automatically centers the height of the extrusion with its 
sketch. 

 

 Press Enter to confirm. 

Create the grooves 

 Left-click on layer 0 to hide the bases. 

 Start the Wood context.  

 Start the Groove function.  
 

 Select Sweep = Planar face and select the top face of the seat as the reference face. 

 

 Select the left-hand edge of the seat in the Reference edge or curve for tool path field. 

 
 

 Click on Stop to confirm. 
 
Two red arrows appear. They represent the direction of the machining 
and the gap side of the groove. 

 The gap must be towards the inside of the part. If this is not the case, 
click on the arrow to invert. 

 

 Once set, click OK to confirm. 
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The groove settings window opens. 

 Configure the various points mentioned below, from the top to the bottom of the window. 

 Select a Routers type tool.  

 In the list, select Simple mill. 
 
 

 In Parameters, enable the High arm option. 

 Enter the following parameters:  

- Gap distance = 170mm 
- Groove width = 80mm 
- Groove depth = 15mm 
- Angle = 0° 

 

 Click OK to confirm the parameters. The groove is produced automatically. 

 

 Without quitting the function, click on Copy operation.  

Note: The Copy operation function repeats the last operation with the same parameters. 
Warning: When using Copy operation, if one of the copied operations is modified, all the copied operations are 
modified. 
 

 Then again select the top of the seat as the reference face. 

 In the Reference edge or curve for tool path field, select the edge opposite the previously selected edge. 

 Click on Stop to confirm. 

The second groove is now created. 

 Press Esc to exit the function. 

 Left-click on layer 1 to display the bases. 
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Data definition 

Define the seat 

Note: Defining the parts allows different properties to be assigned to them so that they can then be identified 
and processed, for example in the BOM, drafting, export for sawing, etc. 
The part definition is used to assign a designation, a reference, a cut, a material, etc. 

 In the Wood context , use the Define > Define part function.  

 In the dialog bar, set the following: 

- Assembly = Main assembly 
- With sawing-up = Yes 
- Select axis automatically = Yes 
- Bent part = No 

 

 Then select the previously extruded 
seat in the graphics area. 

 
 
 
 
 
 
 
 
 

Note: The With sawing-up = YES option allows you to define the part with its calculated sawing-up dimensions. 
For hardware for example, not calculating the sawing-up improves software performance. 
The Select axis automatically = YES option is used to automatically determine the length and width axes on the 
part. On complex shaped parts, the length and width axes can be selected manually. 
The Bent part = NO option is used to unfold bent parts in order to calculate its precise cut when flat. 

 Click OK to confirm the dialog.  

The Part definition window opens automatically. 

 
Note: The general properties of the part, such as its 
designation and reference are shown in the top part of the 
window. 
The specific properties are then classified in the various tabs, 
such as Cutting-up, Material and Description. 

 In the top part of the window, enter Designation: Bench 
seat. 

 In the Material tab, select the TopSolid'Wood > 
Hardwoods material category in the drop-down list, then 
the Oak european material. 

 Click OK to confirm.  
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Define the bases 

 In the Wood context, use the Define > Define part function.  

 Set the following: 

- Assembly = Main assembly 
- With sawing-up = Yes 
- Select axis automatically = Yes 
- Bent part = No 

 Select the bases. 
 
Note: The bases are repeated parts, so they have the same definition. Therefore, all the parts of the repetition are 
selected. 

 
 

 

 In the top part of the window, enter: 

- Designation: Metal base  
- Reference: ME-BA 
- Supplier: Metal company 
- Part category: Bought 

 

 In the Material tab, select steel in the steel category. 

 In the Coating tab, select mat black paint in the paint 
category. 

 Click OK to confirm. 
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Define the set 

Note: Defining the set allows properties to be attributed to the newly created set of parts. This allows the 
assembly to be properly identified and processed later in BOMs or drawings for example. 
The definition of a set is used to assign a designation, a reference, etc. 
When two parts are defined in the project, you will automatically be prompted to define the set. 

 Answer Yes to the question.  
 
 
 
 
 
 
Note: You can define the set manually using the Wood > Define > Define set > Characteristics 

function.  

 
 
 
 

 In the Designation field, enter Indoor bench 

 In the General tab, deactivate the Add to sawing-up field. 

Note: Adding the set to sawing-up allows the enclosing dimensions of the set to be 
calculated. But if this information is not useful, then deactivating the tick box will speed 
up the calculations. 

 

 In the Assembly nature section, tick the Sub-assembly option. 
 
Note: At this point, three assembly modes are possible: 

- The Single unit mode: displays the BOM of the assembly without showing the component parts. 

 

- The Sub-assembly mode: displays the BOM of the assembly and the component parts. 

 

- The Content mode: displays only the parts contained in the assembly, without showing the assembly. 

 

 Click OK to confirm. 

 Save the file.  

 Configure the rendering by opening the Rendering  icon and selecting the realistic rendering + edges 

mode.   
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Creating a draft 

The goal of this exercise is to create a draft of the 
complete indoor bench. 

Concepts addressed: 

- Creating a draft document 
- Positioning a main view 
- Editing the draft 
- Positioning auxiliary views 
- Applying the dimensions 
 
 
 
 

Create a new draft document 

 Create a new document.  

 Select a Draft type document. 

 In the Advanced parameters,  select a standard Associative 
A4 Horizontal template. 

 

 Click OK to confirm. 
 
 
 
 
A vertical tab group is automatically created in order to make the work between the Design document and the 
Draft document easier. 
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Position the main view 

 In the View  context, select the Main view function.  

 Select Assembly to draft the entire document.  

 In Pick on the document containing the assembly, select the 3D document by 
clicking on it. 

 

The View creation window opens. 

 Configure the main view by positioning the green arrows as shown opposite. 
 

 Set the smooth edges to Hidden, and the hidden lines to Stipple. 

 Click OK to confirm. 

 Left-click to position the view. 
 
Note: By default the scale of the draft is 1. Scaling is then applied to the entire draft in order to be applied to all 
the views. 
If the scale of the view is OK, auxiliary views can be created on the fly using the Auxiliary view button. 

 

Edit the draft 

 Use Modify element  and select the frame of the sheet. The Edit window opens. 

 Deactivate the Center mark, Orientation mark, Coordinate system and Graduations 
tick boxes. 

 Set the scaling factor to 0.1. 

 

 Click OK to confirm. 
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Note: These elements can be used to configure the graphical items on the sheet. 
 

Border and margins Center mark 

 

 
 

 

 

Orientation mark Coordinate system 

 

 
 

 

 

Graduations  
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Note: As soon as a view is modified, it must be recalculated. 
In this way, all the views in a draft are only recalculated once after making several modifications in order to 
improve performance, in particular on big projects. 

 Use Regenerate , then select the view to recalculate it. 

 Use Move parents  to move the view to the 
top left-hand corner of the draft.  

 Save the draft using the disk icon. . Keep 
the default name. 

 
 
 
 
 
 
 
 
 

Note: If the draft only contains one assembly or one part, the document is automatically renamed as this 
assembly or part. 

Position auxiliary views 

 Use the Auxiliary view function.  

 Validate the default parameters and position the 

auxiliary view using Auxiliary view.  

 Place the cursor to the right of the main view, then 
click to position the view. 

 
 
 
 
 
 
 

 Select the first positioned view as the reference 
view. 

 
 Configure the smooth edges and hidden lines as 

Hidden. 

 
 

 Position the view with Auxiliary view. Position this 
view beneath and to the right of the main view. A 
perspective view is automatically generated. 

 Use the Move parents function.   
Center the perspective view on the width of the 
draft. 
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Dimension the views 

 Start the Dimension context.  

 Use the Fast dimension function.  
 
Note: The Fast dimension function is used to quickly size a drawing element: 

- Click on a segment to dimension the length. 
- Click on an element, then a second element to dimension 

the distance between them. 
- Click on an segment, then a second, non-parallel segment 

to dimension the angle between them. 
- Click on a circle to dimension its diameter/radius. 
 

 Place the different dimensions, such as the 
length/width/height of the bench, the dimensions of the 
base and the dimensions of the seat, on the drawing. 

Fill in the title block 

 Use Modify element  and change Title 1 to Indoor bench. 
Replace Company by TopSolid’Wood and Document number by Document 1/1. 

 Use Delete element  to delete Address 1 and Address 2. 

 Save the document. 
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Exercise 5: Creation of a shelf by bottom-up assembly 

The goal of this exercise is to make three standard production parts, then assemble them to make the shelf. 

Concepts addressed: 

- Using design colors 
- Including files 
- Assembling by constraint 
 
 
 
 

Making the parts 

Make the first part 

 Create a new document of the Design type. 
In the Advanced parameters, select Without template. 

 Change the design color by opening the Color tab. 
Select Spring green (24). 

 
Note: The design color is used to draw different design elements in a specific color. 

 

 Start a new sketch on the current coordinate system. 

 Draw the sketch shown below. The 400mm and 19mm dimensions are constrained along the X and Y axes. 

 

 Finish the sketch, then extrude the part by a height of 150mm. 
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Define the part 

 In the Wood context, use the Define > Define part function.  

 In the dialog bar, set the following: 

- Assembly = Main assembly 
- With sawing-up = Yes 
- Select axis automatically = Yes  
- Bent part = No 

 Then select the created part. 

 In the top part of the window, enter: 

- Designation: Shelf part 1 

 

 In the Material tab, select Lime european in the TopSolid'Wood > Hardwoods category. 

 Click OK to confirm. 

 Save the file an keep its default name. 

Make the second part 

 Draw the sketch shown below in a new Design document. 

 Use the design color blue (12). 

 

 Extrude the sketch to a height of 150mm. 

 Define the part: 

- Designation: Shelf part 2 
- Material: TopSolid'Wood > Hardwoods > Lime european 

 Save the file in the Shelf by bottom-up assembly folder. 

Make the third part 

 Draw the sketch shown below in a new Design document. 

 Use the design color light orange (7). 

 To draw this rectangle, use the command Sketch  > Contour  > Rectangular  to directly 
draw a rectangle. 

 
 Extrude the sketch to a height of 150mm 

 Define the part: 

- Designation: Shelf part 3 
- Material: TopSolid'Wood > Hardwoods > Lime 

 Save the file in the Shelf by bottom-up assembly folder.  
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Assembling the shelf 

Note: Bottom-up assembly allows all or some of the parts contained in another file to be assembled in a file. 
For example, this allows the same standard component to be inserted several times in one or more files. 

 Open the three files you have just created.  

Create the bottom-up assembly file 

 Create a new document of the Design type. In the Advanced parameters, select Without template. 

 Save this file in the Shelf by bottom-up assembly folder and rename it Shelf assembly. 

 Start the Assembly context.  

 Use the Include assembly/Part.  

 

- Explore: Opens a browser to include a file stored in a folder. 
- Partial include: Includes only one or a few parts from a file. 
- Auxiliary elements = No: Only includes the auxiliary elements of the selected document. 
- Component template document: Used to select the document to be inserted in the current document, 

either using the drop-down list that contains the open files, or by directly clicking in the document to be 
included. 

 Select Part 1 in the drop-down list. 

The document Part 1 is included in the current 
document. 

 Select Other positioning. 

 

 The template document of the part opens. Select the absolute coordinate system. 

 

 Then select the absolute coordinate system of the 
assembly document as the destination coordinate 
system. 

 Press Esc to exit the function. 
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Place and constrain the second part 

 Insert Part 2 using Include Assembly/Part.  
 

 Select Part 2 in the drop-down list.  

 Left-click in the space to release the part. 
 
Positioning constraints can now be applied to 
the inserted part. 
 
 
 

 In the dialog, set Type = Auto to automatically choose the type of constraint to be used and Magnetic = Yes 
to dynamically display the result of the constraint. 

 

 

 Select the chamfer of the blue part as the origin geometry. 
 
 
 

 Select the chamfer of the green part as the destination 
geometry. The blue part is positioned accordingly. 

 
The following dialog is used to configure the newly created constraint. 

 

- Type = Since several constraints are possible, it is possible to select the type of constraint used. 

 Select the Mate constraint. 

- Distance = A gap can be included in the constraint. 

 Enter 0mm. 

 Click OK. 

Note: When a positioning constraint is created, a label appears pointing to the constrained face. 
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These labels are divided into four parts : 

- The first part corresponds to the icon of the created constraint (plane on plane, axis on axis…). If the cursor 
is positioned on the icon, a graphical echo shows the constrained elements on the part. 

- The second icon is used to modify the distance between the two constrained elements, if possible. For 
example, for a plane on plane constraint, this allows you move the planes closer or farther away from each 
other. You can enter the distance value manually, use the + or – buttons, or drag the slider. Before using 
the + or – buttons or the slider, a step must be specified. 

 

For certain constraints, it is not possible to specify an offset (axis on axis for example). This field will then not be 
available. 

- The third icon is used to invert the constraint. 

- The fourth icon deletes the constraint. 
 

 More constraints can be placed in the dialog. Select the rear edge of 
the blue part as the origin geometry. 
 
 

Note: If you have difficulty selecting an element (rear face or edge on a 
face), then you can use the rotary selection. Left-click and hold, then 
right-click to navigate between the various superimposed elements. 
 
 

 Select the front edge of the green part as the destination geometry. 
 

 Click OK to validate the next dialog, with Type = Alignment and 
Distance = 0mm. 

 
 

 Place one last constraint, so that the green part has no more degrees 
of freedom. 
Select the lower edge of the blue part as the origin geometry. 

 
 
 
 
 
 
 

 Select the lower edge of the chamfer of the green part as the 
destination geometry. 

 Press Esc to exit the function. 
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Include and constrain the third part 

 Insert Part 3 using Include Assembly/Part.  

 Select Part 3 in the drop-down list, then place it 
in the document. 

 
 
 
 
 
 

 Apply constraints to part 3 to position it as shown 
opposite: 

- Part 3 edge / Lower face of Part 1. 
- Part 3 front edge / Front edge of Part 1. 
- Part 3 right face / Part 1 right edge. For this 

constraint, enter a distance of 150mm. 

 

 
 
 

 Finish positioning by clicking Stop.  

 The next dialog can be used to directly repeat the inserted part. Do not repeat the part with No propagation. 

 
 

Place other parts 

 The next dialog can be used either to place another part 3, or to select another part to be inserted using 

Other component.  

 Continue to place the parts until you reach the final result. 

 Use the realistic rendering in the Rendering tab. 

 >  

 Open the View  tab and select Configure view.  

 In the list, select Conical perspective. 

 

Note: Conical perspective allows for perspectives with a vanishing point. It offers a more realistic view, but is 
more difficult to use. 

 Save the document. 
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Definition of the assembly 

 Define the assembly using the Define > Define set  command from the Wood context. 

 Select Characteristics.  

 Enter Designation: Bottom up assembly shelf and 
Reference: SHE. 

 
 

 In the Assembly section, tick the Sub-assembly option. 

 Click OK to confirm. 

 Save the file. 
 
 
 
 
 
 
 
 
 

Creating a draft 

Create a new draft document 

 Create a new document.  

 Select a Draft type document. 

 In the Advanced parameters,  select a standard Associative 
A4 Horizontal template. 

 

 Click OK to confirm. 
 

Position the main view 

 Start the View  context and select the Main view function.  

 Select Assembly to draft the entire document.  

 In Document containing the set, select Shelf assembly in the drop-down list. 
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 Configure the main view by positioning the green arrows as shown opposite. 
 

 Set the smooth edges to Hidden, and the 
hidden lines to Stipple and click OK to confirm. 

 

 Position the view. 
 
 
 
 

Edit the draft 

 Use Modify element  and select the frame of the sheet. Deactivate the Center 
mark, Orientation mark, Coordinate system and Graduations tick boxes. 

 Set the scaling factor to 0.1. 

 

 Click OK to confirm. 

 Use Regenerate , then select the view to update it. 

 Use Move parents  to move the view to the top left-hand corner of the draft. 

 Save the draft using the disk icon.  

 

Position auxiliary views 

 Use the Auxiliary view function.  

 Configure the smooth edges and hidden lines as Hidden. 

 
 

 Position the view with Auxiliary view.   

 Position this view to the right of the main view. 

 Select the main view as the reference view.  
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 Set the smooth edges and hidden lines to Hidden, 
then place the view using Auxiliary view. 

 Position this view beneath and to the 
right of the main view to generate a perspective 
view. 

 Use the Move parents function.  
Move the perspective view under the main view. 

 
 
 
 

Dimension the views 

 Start the Dimension context.  

 Use Fast dimension  to apply the various dimensions to the drawing:  

- depth of the shelf; 
- length and total height of the shelf; 
- dimensions of the parts. 
 

Note: If a dimension must rest on a point, use the 

Point option in the dialog bar to select a point.  
 
If a dimension is positioned between two points, the 
orientation can be changed in the dialog bar. 

 
 
 

Fill in the title block 

 Use Modify element  to change the title block text Title 1 to Shelf. 
Replace Company by TopSolid'Wood and Document number by Document 1/1. 

 Use Delete element  to delete Address 1 and Address 2. 

 Save the document. 
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Supplement: Adding elements to the draft 

Add a BOM 

 Start the Bill of materials  context, then execute Bill of materials.  

 In the Standard tab, select the BOM TopWood IdxNbDesRefMatComLenWidTh. 

 

Note: The BOM templates display various information columns for each part. 
Standard templates are provided in TopSolid'Wood but you can also produce your own custom templates. 

 In Designate a 2D view, select the main view of the document. 

 Set Depth = Flat BOM and in the Position of bill of material or title block field, select the document title block 
to directly place the BOM. 

 

 

Add coordinates 

 Use BOM index  in the Bill of materials context. 

 In the Element to index field, select a part to be indexed in the views. Place the index. 

The BOM index is generated automatically and the BOM is completed accordingly. Index numbers are created in 
the order the parts are selected. 

 Position indexes to index the three parts. 
 
Note: BOM indexes can be placed on perspective views. 
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Add a perspective view as the 3D 

The steps described below place a realistic view in a draft as a 3D 
design view. 
 
 
 
 
 

 With the draft file open, open the 3D design document. 

 Open the View  tab and select Configure view  to configure the 3D view with conical 
perspective. 

 
 

 In the list, select Conical perspective.  

 Orientate the view, then save the file. 

 From the tab bar, right-click on the shelf draft 
document's upper tab and select New vertical tab 
group. 

 
 
 
 

 
 

 Activate the View  context, then use the Main view function.  

 Select Assembly, then click directly in the 3D design document to select the shelf assembly.  
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 In the view creation window that opens, click in the or 3D view or 3D coordinate system or face field. 

 

 The click in the 3D document space to configure the draft view as the 3D view. 

Note: The draft view is a conical perspective view positioned as the 3D document. 
 

 Set the smooth edges and hidden lines to Hidden, then tick the Shading view 
box. 

 

 Click Colors > Visible lines and choose Black as the color to be used.  
 
 
Note: The Shading view option displays the view in the design colors. The following setting displays the shading 
view with realistic rendering. 
 

 Confirm the window with OK, then place the view. 

 Open the document properties of the draft.  

 In the Projection parameters section, tick Use 
realistic rendering. 

 
 

 Click OK to confirm. 
 
 
 
 
 
 

The shaded view is now displayed in realistic rendering. 
 

 Save the draft. 
 
Note: This setting can be applied to a Draft document 
template so that it does not have to be applied to 
every draft. 
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Exercise 6: Creation of basic shapes 
Shapes are used to quickly design complex shaped parts. However, the shaping operations performed are not 
recognized as machinings. 
For example, shapes can be used to easily create hardware parts. 

 
 

 

Cylindrical button 

In this exercise, you will learn about: 

- Creating cylinders 
- Using design colors 
- Creating Cartesian points 
- Subtracting shapes 
- Fillets on shapes 

 
 

Create the first cylinder 

 Create a new document of the Design type and select Without template. 

 In the context bar, activate the Shapes context.  

 Create a cylinder.  

 Enter a diameter of 20mm. 

 

 Select the Z+ direction. 

 

 Select Alignment = Normal and enter a height of 30mm. Press Enter to confirm. 

 Select the point of origin of the absolute coordinate system to place the cylinder. 
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Create the second cylinder 

 Change the design color using the black tab of the Color icon.  
Select blue (12). 

 Use the Tools > Point function. 

  

 In the function bar, select Cartesian point.  
 
Note: The Cartesian point is used to create a point from another point by 
offsetting it by a distance in the X, Y and Z axes. 
 

 Select the origin point of the absolute coordinate system as the origin point. 
Then enter 10, 0 and 16mm as the X, Y and Z coordinates. 
Place the dimensions of the point to X and Y and press Esc to exit the function. 

 Start the Cylinder function.  
Create a new cylinder with a diameter of 18mm and in the Y+ direction. 
Select Alignment = Centered and enter a height of 30mm. 

 
 

 Select the Cartesian point as the alignment point. 
 

Subtract the cylinders 

 Start the Subtract function.  
 
Note: The Subtract function is used to subtract one shape (Tool) from another shape (Shape to modify). 

 In Shape(s) to modify, select the first grey cylinder. 

 

 Set Hide tools = Yes and Fillet radius = 2. 

 
 
Note: The Hide tools option is used to automatically hide the parts used as tools for the 
subtraction. 
The Fillet radius option automatically generates fillets on the edges created by the 
subtraction. 

 In Tool shape(s) to use, select the blue cylinder to be subtracted from the grey cylinder. 
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Make fillets 

 Start the Fillet function.  

 Select Fillet = One radius, Follow tangent edges = YES and Radius = 2mm. 

 In Edge or face, select the top face of the grey cylinder. 

 
 
The fillets are shown in red before they are made. 

 Create the fillets with the Compute fillet(s) option.  
 
 

Define the part 

 Start the Wood context and select Define > Define part.  

 In the dialog bar, set the following: 

- Assembly = Main assembly 
- With sawing-up = No 

Note: As it is a hardware part, you don't need to calculate its sawing-up dimensions and its material 
overdimensions. It is then possible not to add it to sawing-up to get the best performance when calculating bills 
of material. 

 Select the newly created button as the part to define. 

 In the Part definition window, enter Designation: Cylindrical 
button. 

 
 

 From the Material tab, select the Aluminum material in the TopSolid'Wood > Metals category. 

 

 Click OK to confirm. 

 Save this file in a new folder called Handle shapes. 

 Close this file. 
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Conical button 

In this exercise, you will learn about: 

- Creating a cone 
- Extruding on a face 
- Uniting shapes 
- Chamfers 

 

Create the cone 

 Create a new document of the Design type and select Without template. 

 In the context bar, activate the Shapes context.  

 Create a cone.  

 Select Cone = Truncated and enter a diameter of 15mm. 

 

 Select the Z+ direction. 

 

 Select Alignment = Normal 

 

 And in Constraint = Height/Angle mode, enter Height = 20mm and Angle = -20°. 

 

 Place the shape by selecting the absolute coordinate system origin point as the alignment point. 

 

Note: When selecting a point, the Enter key can be used to automatically select the origin point of the current 
coordinate system. 

Extrude the base 

 Start the Create extruded shape function.  

 Set Extruded shape on = Face. 

 

 Select the base face of the cone as the reference face. 

 
 

 Extrude this face downwards to a height of 5mm. 
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Unite the parts 

 Use the Unite function.  

 Select the cone in Shape(s) to modify. 

 

 In Hide tools = YES mode, select the previously extruded base in Tool shape(s) to use. 

  

Note: The Unite function is used to merge two 3D shapes. One shape is created from the two selected shapes. 

Make the chamfer 

 Start the Chamfer function.  

 Set Chamfer = Length/Length and First length = 2mm. 

  

 

 In Edge or face, select the top face of the cone. 

The chamfer is shown in red before it is created. 

 Create the chamfer with the Compute chamfer(s) button.  

Define the part 

 In the Wood context, start Define > Define part.  

 In the dialog bar, set the following: 

- Assembly = Main assembly 
- With sawing-up = No 

 Then select the newly created part. 
 

 In the Part definition window, enter Designation: Conical button. 

 In the Material tab, select the Aluminum material in the TopSolid'Wood > Metals category. 

  

 Click OK to confirm. 

 Save this file by renaming it Conical button, then close the file. 
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Square button 

In this exercise, you will learn about: 

- Creating a block 
- Drawing an offset point 
- Creating spheres 
- Trimming by shape 

 

Create the block 

 Create a new document of the Design type and select Without template. 

 From the context bar, activate the Shapes context.  

 Create a block.  

 Enter: 

- X length = 20mm and X position = Centered 
- Y length = 20mm and Y position = Centered 
- Z length = 30mm and Z position = Above (+Z) 

 

 

 Select the origin of the absolute coordinate system as the alignment point. 
 

 

Create the sphere 

 Create a point that is offset from the origin of the absolute coordinate system in the Z-

direction at a distance of 15mm using Tools > Point > Offset point.  

 Create a sphere using the Sphere function in the Shapes context.  

 Enter a diameter of 90mm and select the newly created point as the center point. 

 
 

Trim the block 

 Execute the Shape > Surfacic / boolean operations > Intersect command. 

  

 Select the initial block as the shape to trim. 

 Set Hide tools = YES and Fillet radius = 1. 

  

 Select the sphere as the tool shape. 
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Make the fillets 

 Create fillets with a 5mm radius on the four vertical edges of the block.  

 

 

Define the part 

 In the Wood context, start Define > Define part.  

 In the dialog bar, set the following: 

- Assembly = Main assembly 
- With sawing-up = No 

 Then select the newly created part. 
 

 In the Part definition window, enter Designation: Square button. 

 In the Material tab, select Aluminum in the TopSolid'Wood > Metals category. 

 Click OK to confirm. 
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Supplement: Configured line handle 

In this exercise, you will learn about: 

- Creating/using parameters 
- The notion of shapes again: cylinder, union, fillet 

 

Create the parameter 

 Create a new document of the Design type and select Without template. 

 Start the Create function in the Parameter menu.  

 

 Select Unit type = Length and enter a value of 128mm. Press Enter to confirm. 

 

 In the Name field, enter hl. In the Designation field, enter Handle length. 

 

Note: The name is the system name of the parameter. This name will be used in the value fields or in expressions. 
The name must be simple and cannot contain any spaces. 
The designation is what the user sees when using the parameter. Therefore, it must be explicit in order to use the 
parameter and can contain spaces. 

 Click OK to confirm, then click No text.  

Note: The name and value of the parameter can be displayed in the graphics area so you can edit them. In order 
not to overload the project, the texts of the parameters are not displayed. 

 Press Esc to exit the function. 

Create the offset points 

 To create an offset point, open the Tools > Point > Offset point menu.  

 Select the origin of the absolute coordinate system as the origin point, X+ as the direction, and the 
expression hl/2 as the distance. 

 

 Apply the dimension, then repeat the operation to create an offset point from the origin of the absolute 
coordinate system in the X- direction by a distance of hl/2. 

 Finish by creating an offset point from the origin of the absolute coordinate system in the Z+ direction by a 
distance of 20mm. 
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Create the cylinders 

 From the Shapes  context, create a cylinder  with a diameter of 10mm, in the Z+ direction and a 
height of 20mm in the Alignment = Normal mode. 

 

 In Alignment point, select the two offset points in the X axis created previously. 

 

 
 

 Create another cylinder with a diameter = 10mm, in the X+ direction and a height = hl+30 in Alignment = 
Centered mode. 

 In Alignment point, select the offset point towards Z+. 

 
 

Unite the cylinders 

 Use Unite  to unite the left-hand cylinder (Shape to modify) and the upper cylinder (Tool shape to use). 
Use the Hide tools = YES mode. 

 

 Unite the two previously united elements (Shape to modify) with the right-hand cylinder (Tool shape to use). 

The three cylinders now form a single part. 
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Make the fillets 

 Create fillets with a radius = 3mm on the two end faces of the upper cylinder. 

 

 Validate the fillets with the Compute fillet(s) button.  
 

Define the part 

 In the Wood context, start Define > Define part.  

 In the dialog bar, set the following: 

- Assembly = Main assembly 
- With sawing-up = No 

 Then select the newly created part. 
 

 In the Part definition window, enter Designation: Line handle 

 In the Material tab, select Aluminum in the TopSolid'Wood > 
Metals category. 

 Click OK to confirm. 

 Save this file by renaming it Line handle, then close the file. 

Vary the length of the handle 

 Start the Modify parameter function.  

 In Parameter to modify, enter hl, then press Enter to validate. 

 

 Change the nominal value of the parameter hl, then press Enter to validate. 
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Exercise 7: Creation of a bottle rack 

In this exercise, we are going to make a bottle rack. 

Concepts addressed: 

- Same length constraint 
- Sketch copy 
- Part duplication 
- Pocket and drilling operations 
 

Making the supports 

Draw the sketch 

 Create a new document of the Design type and select Without template. 

 Start a new sketch on the current coordinate system. 
 
 
 
 
 

 Draw and dimension lines 1 and 2 as shown opposite. 

- Lines 1 and 2 are oriented along the X axis. 
- Line 1 is aligned with the X axis. 

 Show the extremities. 

 Draw the circle arc 3 and apply a tangency constraint 
with line 1. 

 Draw lines 4 and 5. 

- Line 4 is dimensioned at a 70° angle relative to line 1. 
- Line 5 is aligned with line 4. 
- Dimension the distance between the two points to 

220mm. To set the dimension parallel to the lines, in 
the dialog bar set Orientation = Parallel. 

 
 
 
 
 

 Open the Constraint  function, then select the Same length constraint.  

 Select line 4, then line 5. 

Note: It is possible to select several segments to be constrained to the same length. 

 Click on Stop to finish.  
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Draw the additional lines 

 Draw lines 6 and 7. 

 Apply a perpendicularity constraint to lines 6 and 7, 
relative to lines 5 and 4. 

 Dimension lines 6 and 7 to a length of 40mm. 
 

 Then draw a circle arc between lines 6 and 7. 

 Dimension this circle arc to a radius of 20mm. 

 Then apply a tangency constraint between this arc and 
line 7. 

 
 

 
 
 
 
 
 
 
 
 
 

 
 
 
 
 

 Finish by drawing the upper line, as shown opposite. 
This line is oriented along the X axis and the right-hand 
point of the line is aligned with the Y axis. 
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Copy the elements of the sketch 

Note: The Copy sketch function is used to copy segments of a sketch with a transformation.  
Copy sketch can copy the orientation constraint applied the the copied segment at the same time. 
Copy sketch also copies the dimension constraint of the segment (length, radius, etc.), but it does not copy the 
constraints between the segments. 

 Start the Copy function.  

 Set Duplicate orientation constraints = YES. 

 
 
Note: In certain functions, it is possible to select several graphical elements and apply the function to them. The 

selection lasso is active in these cases.  

 Start the selection.  

 In Template elements to repeat, select segments 1, 3, 4, 
5, 6, 7, the circle arc and the upper segment. 

Note: The selected elements are highlighted in grey. 

 Click on OK to confirm the selection.  

 Select Simple mirror in the drop-down list as the 
propagation.  

 Select the YZ plane as the symmetry plane.  
 
 
 
 
 
 
 
 
 
 

 
All the selected segments are copied by simple mirror. 
The dimensions associated with the segments and the 
dimensions and constraints between the segments are 
also copied. 

 Finish by dimensioning the distance between the 
right-hand point of segment 1' and the Y axis of the 
absolute coordinate system at 150mm. 

 
Note: The Move parents function can be used to 

reposition the dimensions on the plane.  
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Make the fillets 

 Use Fillet to make fillets with a radius = 10mm on the ten angles in the sketch. 

 Set Mode: Global to create the fillets on all the sketch's angles in one go. 

 >  

 Finish the sketch. 

 Save this document in a new folder Bottle rack, then rename the file Bottle rack. 

Extrude the sketch 

 Extrude the sketch in the Z+ direction.  >  
Enter Offset from starting curve = 100mm in the advanced parameters. 

 >  

Enter Height = 10, then press Enter to confirm. 

 
 

Modify the sketch 

Note: Once a drawing element has been used (e.g., when a sketch is used to 
extrude a part), it is automatically hidden. Use the Driving elements function to 
display the elements used by another element. 

 Open Driving elements , then select the extruded part. 

 Use Modify element  to modify the displayed sketch. 

 Use Modify parameter  to modify the radius of the circle arc 8 to the 
nominal value = 45mm. 

 

 Finish the sketch. The extrusion of the part is automatically recalculated. 

 Use Driving elements again on the extruded part to hide the sketch.  
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Duplicate the support 

Note: The Duplicate function creates a copy of an existing part. It can be used to create two parts with an 
identical basis, which are then distinguished as a left-hand side and a right-hand side with different machining 
operations. 
Two duplicated parts can be defined differently. 

 Start the Edit > Duplicate function. 

 Select Rotation , then the Y+ axis as the rotation axis.  

 Enter a rotation angle of 180°, then press Enter to confirm. 

 

 Set Follow = Existing operations. 

 

Note: The Follow existing operations option applies only the existing operations to the duplicated part. 
The Follow subsequent operations option is used to apply subsequent operations to the duplicated part. 

 Leave the Layer number or name field empty. 

 

Note: The Layer number or name option is used to change the destination 
layer of the duplicated part. 

 Select the previously extruded part in Elements to duplicate. 

 

Machining the supports 

Make a sawing 

 Start a new sketch on the current coordinate system. 

 Position a circle with a diameter of 90mm. 

 

 Apply an alignment constraint between the center of the circle 
and the Y axis. 

 Dimension the center of the circle with the X axis at an offset of 
206mm. 

 Finish the sketch. 

 Start the Wood  context, then select Sawing.  

 Select one of the two supports in Shape(s) to saw. 

 

 Select the drawn circle in Sawing path curve. 

 

The red arrow represents the offcut side. 

 Position the offcut inside the circle by clicking on it and using the 
Invert direction 

 

 Click on OK to cut. 
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Make a drilling 

 Start the Drilling function.  

 Set Coordinate system = Constraint and Mode = Non dynamic. 

 

Note: The Coordinate system = Constraint mode places the drill hole in 
relation to dimensions or constraints. 
With the Mode = Non dynamic option, it is not necessary to apply 
dimensions directly to the drill hole. The Mode = Dynamic option 
automatically places the drill hole with the dimensions on the nearest 
edges. 

 Select the inner face of the unsawn part as the face to drill. 
 
 

 Then, in First alignment face or edge select the edge of the sawing circle arc. 

 

Note: When selecting the edges for a drilling operation, selecting a circle 
allows the drill hole to be positioned automatically in the axis of the 
selected circle. 

 From the Drilling models window, select Hole in Standard models, 
then click OK to confirm. 

 

 Select Hole - Through one, then enter a diameter of 40mm. 

  
 

 Click on OK to confirm. 
 

Making the support rods 

Draw the sketch 

 Make layer 1 current.  

 Start a new sketch on the current coordinate 
system, then position four circles with a 
diameter = 10mm as shown opposite. 

 

 Use Dimension to dimension the positions of 
the four circle centers: 

- Left bottom: X=-100; Y=30 
- Right bottom: X=100; Y=30 
- Right top: X=60; Y=170 
- Left top: X=-60; Y=170 
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Extrude the rods 

 Finish the sketch. 

 Start the Create extruded shape function. 

 Use the Sketch = Global and Result = One shape per curve modes. 

Note: The Sketch = Global mode is used to extrude any sketch in one go. 

In this case, the Result = One shape per curve mode is used to generate four distinct shapes. 
In the Result = One shape mode, only one shape is produced. 

 
 
<= Result = One shape 
 
 

Result = One shape per profile => 
 
 
 

 
 
 
 
 
 

 Select one of the circles in Section curves or texts. 

 In the dialog bar, set Alignment = Centered, enter a height of 210mm, and press Enter to confirm. 

  

Drilling the faces 

 Start the Drilling function.  

 In Face to drill, select the lower face of a support. 

 In First alignment face or edge, select one of the four extruded cylinders. 

 From the drilling model window, select Hole in Standard models. 

 Tick Save as default. This saves the drilling values for the following drilling 
operations. 

 Click on OK to confirm. 
 

 Configure a blind hole with a diameter = 10mm, a depth = 6mm and a bottom angle = 0°. 

  

 Click on OK to confirm. 

 Repeat the operation to make four drill holes for the rods on this 
surface, then four drill holes for the rods on the opposite face. 
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Definition of the parts and the assembly 

Define the supports 

 Start Wood > Define > Define part, then define the two supports. 

- Designation: Support 1 / Support 2 
- Material: TopSolid'Wood > Hardwoods > Lime european 

 In the Over dimensions fields, add the length and width 20mm lines by double-clicking in the field, then press 
Enter to validate. 

 

Note: The cutting over dimensions can be used to add more 
dimensions to the part's enclosing dimensions for the cutting-up of 
the material. 
The stock can be configured in the Stock tab of the Part definition 
window. 
 

Define the rods 

 Define the four supporting rods. 

Note: Since these parts are cylindrical, users must select their axes 
manually. 

 Select the cylinder of the rod currently being defined as the length 
axis. This means that the length of the rod will be the axis of the 
cylinder. 

  

The axis is shown by a red arrow. Click on OK to confirm. 

 Select X+ as the width axis.  

 Then set: 

- Designation: Support rod 
- Material: TopSolid'Wood > Metals > Aluminum 

 Click OK to confirm, then repeat the operation for all four rods. 

Define the set 

  Start the Wood > Define > Define set function, then select Characteristics. 

 Enter: 

- Designation: Bottle rack 
- Assembly nature: Single unit 

 Click on OK to confirm. 
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Supplement: Adding attaching screws 

 Make layer 2 current.  

 Start the Screw  function from the Wood context. 

 Select Metal screw as the standard component. 

 

 Select the code: D4 L25. 

 Click OK to confirm. 
 
Note: The assembly function is used to place and automatically propagate screws between two parts.  
In this case, the screws are placed individually. 

 In the dialog bar, select Standard positioning.  

 In the destination coordinate system for the screw, select one of the 
outer faces of a support. 

  

 
 
 
 
 
 

 As when positioning the drill holes, select the cylinder of a rod as the 
first alignment face or edge. 

  
 
 
 
 
 
 

 Click Stop to confirm the position of the screw.  

 Select Automatic to automatically machine the drill holes for the screw.  

 Repeat the operations to place the eight attaching screws on the two outer faces of the supports. 

 

 Save the file. 
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Exercise 8: Creation of a rectangular coffee table 
 
The goal of this exercise is to make the rectangular parts 
without using a 2D drawing, and then to perform the wood 
machining operations. 
 
 
 
 
 
 

Designing the table 

Concepts addressed: 

- Creation of a construction volume 
- Using design transparency 
- Using constrained blocks 
 
 

Create the construction volume 

Starting with a construction volume for the design of the table will make it possible to design the parts quickly 
and easily. 

 Create a new Design document and select Without template. 

 Activate the Shapes context, then create a block with the following dimensions: X = 1300, Y = 600 and 
Z = 400. Apply Alignment = Centered to all three dimensions. 

 

 Select the origin of the absolute coordinate system as the alignment point to place the block. 
 

 Start the Transparency function in Attribute > Transparency. 

 Select a transparency of 7.  

Note: Transparency is defined on a scale of 1 to 10. 10 corresponds to maximum 
transparency of the shape (only the edges are visible). 

 Select the construction volume in order to apply the transparency. 
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Create a part as a constrained block 

 

Constrained blocks are used to design parts directly in 3D, without using a 2D drawing of the parts. 
This allows to design parts simply, with a rapid and easy modification. 
 
Constrained blocks are created using a thickness, four dimensioning 
planes and a positioning plane. 
 

Arrows for the dimensioning planes. There are two for 
each dimension. 
 

 
One arrow for the positioning plane. This is used to place 
the block on the right, in the center or on the left of the 
selected positioning plane. 
 

 Make layer 1 the current layer by clicking the thumbwheel on 1.  

 Start the Wood  context, then select Constrained block.  

 Enter a thickness of 30mm. 

 

 In First plane, select one side of the length of the construction volume. 

 

 
 

 Set Mode = Faces, then select the second lengthways side of the block in 
Second plane or point. 

  

 If the block is placed horizontally, click Switch direction to place it 
vertically. 

 
 

 Then select the lower face of the block in First plane. 

 

 
 
 
 

 In Second plane or point, select the top face of the block in Mode = 
Faces. 

  

Note 
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 Then select the end face of the block as the positioning plane. 

 
 
 
 
 
 
 

 Click the yellow arrow on the left to place the constrained block on the 
right of the positioning plane. 

 Enter Positioning shift = 0mm and set Assembly global rules = No rule. 

 

Note: The assembly global rules are used to directly assemble a constrained block using assembly rules. 
These assembly rules will be addressed in the TopSolid'Wood Advanced Training Guide. 

 Validate the constrained block by clicking OK.  
 

Create the other two bases 

 For the next constrained block, enter a thickness of 30mm. 

 In First plane, select the bottom face of the construction volume. 
 
 
 
 

 In Second plane or point, select the top face of the construction 
volume. 

 
 
 
 

 The part must be placed lengthways in the block. If it is placed width ways, use Switch direction to change the 
direction of the part. 

 

 In First plane, select the right-hand face of the construction volume. 
 
 
 
 
 

 In Mode = Faces , enter a second shift of 800mm. 

 

 

 In Second plane or point, select the left-hand face of the 
construction block. 
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 In Positioning plane, select the front face of the construction block. 
Place this constrained block inside the construction block. 

 
 
 
 
 

 Repeat this operation to create the second leg in the lengthways axis 
of the table. 

 Save this file in a new folder called Rectangular coffee table, then 
rename the file Rectangular coffee table. 

Create a constrained block automatically 

 Make level 2 current. 

 

 In Constrained block, select the Automatic mode in the dialog bar. 

 

Note: The Automatic mode automatically generates a rectangular constrained block on one face. 
 

 In Positioning plane, select the top face of the construction volume. 

 

 
 

 

 Select the top yellow arrow to place the constrained block inside 
the construction volume. 

 Validate the constrained block by clicking OK. 
 

Modify a constrained block 

 Switch off layer 0. 

 Open Modify element, then select one of the faces of the left-hand 
base. 

 Then select the upper red arrow. 

 Enter a second shift of 30mm, then press Enter to confirm. 

This allows the top face of the constrained block to be offset by 30mm. 

 Validate the constrained block by clicking OK. 

 

 Repeat this operation for the other two bases. 
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Performing the operations 

Concepts addressed: 

- Sawing 
- Rabbets 
- Grooves 

 

 

Draw the sketch and saw the top 

 Activate the Sketch  context, then start a new 

sketch on the current coordinate system.  

 Create a contour , then select the Rectangular 

button.  

 Draw a rectangle, as shown opposite. 
 
 

 Then use Dimension to dimension the 
distances between the four sides of the 
rectangle and the four sides of the top. 
Set the nominal value to 100mm for 
each of the sides. 

 
 
 
 
 

 Use Fillet  to apply fillets with a fillet radius = 10mm to the four corners of the rectangle. 

 Finish the sketch.  

 In the Wood context, use the Sawing function.  

 Select the top of the table as the shape to saw. 

 Select the sketch drawn previously as the sawing path curve. 

 Click on the red arrow so that it points towards the offcut. 

 Click on OK to confirm. 
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Make the rabbets in the table top 

 In the Wood context, start the Rabbet function.  

 In Sweep = Planar face mode select the top face of the table top as the reference face. 

 

 
Note: The Sweep = Planar face mode is the most 
commonly used mode. It allows the operation to be 
performed on a flat face. 
 
 
 
 
 

 Then set Join edges = YES and Follow tangent edges = YES. 

 

 Select one of the top edges of the saw cut as the 
reference edge or curve for tool path. 

 
Note: Since all the edges of the face are tangential, 
they are all selected in one go. 
 

 Click Stop to confirm the path.  
 
 
 
Note: The two red arrows represent the direction of machining 
and the machining side of the rabbet. 
 

 Set the machining side of the rabbet towards the material of 
the part, as shown opposite. 

 

 Click on OK to confirm. 
 

 In the Parameters window, set: 

- Tool type: Routers  
- In the TopSolid'Wood library, select Simple mill 

- Parameters: On face  
- Rabbet width: 10mm 

 

- Rabbet depth: 5mm 

 

 Click on OK to confirm. 
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Create the grooves 

 Make layer 1 current, then switch off layer 2. 

 

 Start the Groove function.  

 Select Sweep = Planar face and select the outer 
face of a leg as the reference face. 

 
 
 
 
 
 

 Select the lower edge of the leg in the Reference 
edge or curve for tool path field. 

 Click Stop to validate. 

 Set the upward offset of the groove. 

 Click on OK to confirm. 
 
 

 Set: 

- Tool type: Routers 
- Simple mill 
- Parameters: High arm 
- Gap distance = 100mm 
- Groove width = 10mm 
- Groove depth = 5mm  
- Angle = 0°  

 

 Click OK to confirm the parameters. 
 

 Copy the groove operation.  

 Select the outer face of the leg as the reference 
face again. 

 In Reference edge or curve for tool path, select 
the top edge of the leg. 

 Click Stop to validate. 
 
 

 Continue copying the groove until you have made 
the six grooves on the three legs. 

 Switch on layer 2. 
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Finishing the table 

Concepts addressed: 

- Copying an edge contour 
- Extrusion between two faces 

Making the table top 

 Make layer 3 the current layer. 

 Select the design color cyan (26). 

 Start a new sketch. 

 Use the Edge function.  

 Use Mode = Contour and select the top face of the 
table top. 

The edge of the rabbet is automatically copied. 

Note: When selecting the edge to be copied, the reference face is framed in red and the edge to be copied is 
framed in red and white. 

 Finish the sketch. 

 Start the Create extruded shape function, then select the sketch. 

 Select Mode = Two trims.  
 
Note: The Mode = Two trims option allows a part to be extruded between two faces or points, without entering 
the extrusion height. 
 

 Select the bottom of the rabbet in First trimming face or 
point. 

 

 
 

 
 

 Select the top of the table top in Second trimming face or 
point. 

 

 
 
 
 

 Apply a design transparency of 7 to the part using the 
Attribute > Transparency function. 
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Define the parts 

 Use Wood > Define > Define part to define the parts. 

 For the glass table top, enter: 

- Designation: Glass table top 
- Material: TopSolid'Wood > Glasses > Clear window glass  

 For the table top, enter: 

- Designation: Table top 
- Material: TopSolid'Wood > Hardwoods > Oak european 

 For the three legs, enter: 

- Designations: Base 1 / 2 / 3 
- Material: TopSolid'Wood > Hardwoods > Oak european 

Define the set 

 Use Define > Define set > Characteristics to define the set. 

 Enter: 

- Designation: Rectangular coffee table 
- Assembly nature: Sub-assembly 

 Save the file. 
 

Creating a draft 

The goal of this exercise is to create a draft of the complete table. 

Concepts addressed: 

- Section view 
- Dimensioning of wood operations: rabbets and groove 
 
 
 
 
 
 
 
 
 

Create a new draft document 

 Create a new Draft document  and select the standard template Associative A4 Vertical. 

 Click on OK to confirm. 
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Position the main view 

 Start the View context in the draft document.  

 Select Main view in the function bar.  

 Select Assembly to draft the entire document.  

 Select the file Rectangular coffee table in the dialog bar. 

The View creation window opens. 

 Configure the main view by positioning the green arrows as shown opposite. 
 

 Set the smooth edges to Hidden, and the hidden lines to Stipple. 

 Click on OK to confirm. 

 Position the view. 
 

Edit the draft 

 Modify the draft frame using Modify element.  

 Deactivate the Center mark, Orientation mark, Coordinate system and Graduations 
tick boxes. 

 Set the scaling factor to 0.1. 

 

 Click on OK to confirm. 

 Regenerate the invalid view to recompute it.  

 Move parents to place the view at the top of the page in the middle.  

 Save the draft using the disk button.  
Keep the default name (reference of the drafted assembly). 
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Position an auxiliary view 

 Use the Auxiliary view function.  

 Validate the default parameters and position the auxiliary view using Auxiliary 

view.  

 Place the cursor beneath the main view, then click to position the view. 
 
 
 

Create a section view 

 Start the Full section function in the View context.  

 Select the newly created auxiliary view as the reference view. 

 Select Horizontal or vertical cutting curve. 

 
 Place the cutting curve as shown opposite. 

 If the line is horizontal, select Change to vertical in the 
dialog bar. 

 
 

 
 
 
 

 The cutting direction must be to the right. If it is to the left, click Invert in the dialog bar. 

 
 Confirm the cutting line by clicking OK. 

 
 
 

 Set the following in the dialog bar: 

- Alignment = NO 
- Set the section view upright = YES 
- Hidden lines = Hidden 

 

 
Note: If the section view is not aligned, then it does not have to be aligned in the 
plane with the reference view. This means that the view can be placed wherever 
you like. 
The Set the section view upright option is used to set the view upright in the draft. 

 Click OK to confirm the section view parameters. 

 Place the section view under the auxiliary view. 
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Dimension the views 

 Start the Dimension context.  

 Use the Fast dimension function.  

 Place the various dimensions on the main view, the auxiliary view and the section view: 

- General dimensions 
- Dimensions of the bases and the top of the table 
- Dimensions of the glass table top 

Dimension the wood operations 

 Start the Wood context.  

 Start the Groove dimension  function, then select a groove of a base in the section view. 

An information note about the groove is generated automatically. 

 Place this note in the draft. 

 Then use the Rabbet dimension  function and select the 
rabbet in the glass table top in the section view. 

An information note about this rabbet is generated 
automatically. 

 Place this note in the draft. 
 

 
Note: The information that appears when dimensioning the wood operations is configured in Document 

properties > TopSolid'Wood properties > Draft.  

Fill in the title block 

 Use Modify element  to modify the text in the title block: 

- Title 1: Rectangular coffee table 
- Company: Name of your company 
- Document number: Document 1/1 

 Use Delete element  to delete Address 1 and Address 2. 

 Save the document. 
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Supplement: Assembly and configuration 

Concepts addressed: 

- Assembly with dowels 
 

Assembly with dowels 

 Open the 3D design document. 

 Make layer 4 current.  

 From the Wood context, start the Dowel assembly function.  

Note: The Dowel assembly function is used to automatically place dowels between two parts according to a given 
type of propagation. 

The Standard positioning window is used to select the dowel. 

 Select Wood dowel, then select the code D10 L35. 

  

 Click OK to confirm the dowel. 

 In the dialog bar, switch to Filter mode and Propagation = YES. 

  

Note: The Filter mode is used to select only the contact faces between two parts. 
The Propagation = YES mode propagates the dowels on the assembly face. In Propagation = NO mode, only one 
dowel is placed in the center of the width and at a configured distance (in Tools > Options) on the length. 

 In Support face, select the contact face between a 
base and the top. 

 
 
 
 
 
 
 
 
Note: The start and terminate faces correspond to the start and 
the end of the propagation of the dowels (four dowels in this 
case). 
 
The centering face corresponds to the positioning of the 
propagation across the width of the assembly.  
Once you have selected the centering face, you can center the 
dowels across the width by selecting the opposite face or by 
entering a distance to offset them. 
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 Select the front face of the base in Start face or edge. 

 
 
 
 
 
 

 Select the outer face of the base in Centering face or 
edge. 

 
 
 
 
 
 

 To position the dowels in the center of the width, select 
the inner face of the base in Parallel face or edge. 

 

 
 
 

 Select the rear face of the base in Terminate face or 
edge. 

 

 
 
 
The Distribution definition window opens. 
 
Note: In this window, you can use the propagations already defined in Tools > Options by selecting them in the 
Propagation name drop-down list. 
Four types of distribution are then available: Step distribution mode, Step centered, Distance and Advanced. 
Each mode is used for a specific distribution that best meets the need. 
 

 Select the Centered step distribution mode. 
 
Note: In the Centered step mode, the distance between each dowel can be configured, as well as the quantity of 
dowels. The start and terminate distances of the propagation are equal. 
 

 Set the Step to 128mm by selecting 128mm in the Predefined values drop-
down list. 

 Check Optimize the number of elements. 

 

Note: The Optimize the number of elements option is used to automatically calculate the highest quantity of 
dowels that can be placed with the selected step. 
This quantity is recalculated if the assembly is subsequently changed. 
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 Click on OK to confirm.  

The dowels are automatically placed and the parts are drilled. 

 
 
 
 
 
 
 

 Use Copy propagation to copy the assembly 
propagation. 

 

 Repeat this operation for the other two bases. 

Configure the table 

 Create three length parameters using Parameter > Create: 

- Value = 1300mm, Name = L, Designation = Table length  
- Value = 600mm, Name = w, Designation = Table width 
- Value = 400mm, Name = h, Designation = Table height 

 

 

 Switch on layer 0 to display the construction block.  

 Use Modify element to modify the construction volume.  

 Replace the lengths of the block on X, Y and Z with the parameters L, w and h. 

 

 Press Enter to confirm. 

 Switch off layer 0. 

 Change the values of the parameters using Parameter > Edit list. 
 
Note: The Edit list function is used to make several changes to several parameters at the same time. It can also be 
used to create new parameters. 

 Select Document to modify all the parameters created in the document. 

 
 

 Double-click on the Value field of a parameter to change the value. Change the value of the three parameters. 

 Click OK to confirm the changes. 
 
The table is automatically updated with the new dimensions. 
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Supplement: Creation of the exploded assembly for the table 

Note: An explosion allows an assembly to be exploded in a new document. 
This exploded assembly can be created in either of two ways: 

- Automatically: Using two different automatic modes (spherical or radial) and an explosion factor between 
parts. 

- Manually: Parts will be moved relative to other parts by specifying a direction and a distance or a rotation 
and an angle. 

 From the design file of the coffee table, start the Assembly > Create exploded assembly function.  

 Click in the document's graphics area in order to select it. 

Note: If the document to be exploded is not open, you can use the Explore option to select it. 

 From the New document window, select a Design document and validate with OK.  

 Set the following options in the dialog bar: 

- Explode standard components: Yes 
- Explode type = Spherical explosion 

 
 
Note: The Explode standard components option allows a component included in the document via a standard 
library to be exploded or not. 
The spherical explosion enables parts to be exploded in the three dimensions. The radial explosion enables parts 
to be exploded along a circle and a direction. Finally, the None option allows a manual explosion. 
It is still possible to make manual changes to spherical and radial explosions. 

 Validate the settings for the explosion with OK. 

 Enter Spherical coefficient = 1.3 and select the origin of the document's absolute coordinate system as the 
center of explosion. 

 
 
Note: The spherical coefficient allows you to set a more or less important explosion of parts. The center of 
explosion lets you adjust the center of the sphere which will explode the parts. 
 
The spherical explosion is then automatically performed. 
It is then possible to make manual changes to the resulting exploded assembly. If the document is closed, and 
then reopened, you can return to the manual modification of the explosion by selecting the Modify element 

function and clicking one of the exploded elements.  

 
  



Exercise 8: Creation of a rectangular coffee table  TopSolid'Wood Basics 

94   Missler Software 

 Select the wooden table top as the reference part. 

 Then select the top glass plate as the part to move. 

 Validate the part selection with OK. 

 Enter Distance: 100mm and validate with OK. 

 
 
Note: You can also position the parts to move manually by left-clicking in the graphics area. 

 Save and close this document. 
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Exercise 9: Creation of a storage cabinet 
The goal of this exercise is to build a cabinet configured 
with the constrained block in order to reuse it with different 
dimensions in an assembly. 
 
 
 
 
 
 
 
 

Design of the cabinet 

Create the construction volume 

 In a new Design document, create four length parameters with the Parameter > Create function. 

 
 

 Create a block with the dimensions X=w, Y=d and Z=h in Alignment = 
Centered mode. 

 Select the origin of the absolute coordinate system as the alignment point 
to place the block. 

 Apply a transparency of 7 to the block using the Attribute > Transparency 
function. 
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Create the parts 

 Make level 1 current. 

 Start the Wood  context, then select Constrained block.  

 Enter Thickness = th. 

 

 Create the two sides, the top and the base of the cabinet. 

Note: The sides are free-running at the top and the base. 

 

Assemble the parts with dowels 

 Hide layer 0. 

 Start the Wood > Dowel assembly function.  

 Select Wood dowel with the code D8 L35. 

 Set Propagation = YES, then select the contact face between the base and 
the right-hand side as the support face. 

Note: Rotary selection can be used to select the contact face between two parts 
more easily. 

 Select Automatic to automatically detect the start, terminate and centering 

faces.  

 In the Distribution definition window, set:  

- Distribution mode: Advanced 
- Step (p): 128mm 
- Minimum distance to start: 70mm 
- Minimum distance to terminate: 70mm 

Note: The Advanced mode is used to automatically calculate the number of 
units to be placed, on the basis of a step between the units and minimum 
start and terminate distances. 

 Confirm with OK to position the dowels. 
 

 Use Copy propagation, then Automatic to assemble the other parts with dowels.  
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Place the cams 

 Start the Wood > Cams and dowels function.  

 Select Simple cam with the code L24 19. 

 Set Propagation = YES, then select the contact face between the base and 
the right-hand side as the support face. 

 Select the lower face of the base as the face to drill for the case. 

 Select Automatic. 

 In the Distribution definition window, set: 

- Distribution mode: Distance 
- Distance to start: 40mm 
- Distance to terminate: 40mm 
- Element number: 2 

 Confirm with OK to position the cams. 
 
 
 
 

 Use Copy propagation to place the cams on the other parts.  

 

Create the back 

 Make level 2 current. 

 Create the back of the cabinet as a constrained block. 

- Enter a thickness of 10mm. 
- Apply a shift of -8mm to the four planes. 
- Select the inner faces of the sides, the top and the base as planes. 

Note: Entering a negative shift allows the constrained block to be included in 
the selected plane. 

 

 Enter a positioning shift of 10mm, then select one of the rear edges of the 
cabinet as the positioning plane. 

 Adjust the red arrow so that the positioning shift is towards the interior of 
the cabinet, then adjust the green positioning arrow so that there are 
10mm between the rear of the base and the rear of the cabinet. 
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Machining the parts 

Make the groove in the base 

 Start the Wood > Groove function.  

 Set Sweep = Planar face, then select the interior face of the base as the reference face. 

 

 Then select the rear edge of the selected face as the reference edge or 
curve for tool path. 

 Then select Stop. 

 In the groove parameters window, set: 

- Tool type: Routers 
- Standard: Simple mill 
- Parameters: High arm 
- Gap distance: 10mm 
- Groove width: 10mm 
- Groove depth: 9mm 

 Click OK to validate and make the groove. 

 Use Copy operation to make the same groove. 
 

 

Definition of the parts and the assembly 

 Save this file in a new folder called Cabinet and rename the file Standard cabinet. 

Define the parts 

 Use Wood > Define part to define the five parts of the cabinet: 

- Designation: Top 
- Bottom 
- Right-hand side 
- Left-hand side 
- Back 

 Select the material: TopSolid'Wood > Panels > Colors > White. 

Define the set 

 Use Wood > Define set to define the assembly: 

- Designation: Standard cabinet 
- Reference: CAB 
- Assembly nature: Sub-assembly 
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Creating an assembly 

Define the drivers 

 

 
 
 
 
 
 
 
 
 
 
 
 
 

 Open the list of parameters using Parameter > Edit list. 

 The last column Driver can be used to define a parameter as a driver. Double-click in this field to change the 
value of the four parameters to Yes. 

 Click OK to confirm the list of parameters. 

 

 Switch on layer 0, then save the file. 

Assemble the cabinets 

 Create a new Design document. 

 Save this file in the Cabinet folder and rename it Cabinet assembly. 

 Start the Assembly context.  

 Use the Include assembly/Part function.  

 Select Standard cabinet in the drop-down list. 

 

Note: Only the files that are open are included in the drop-down list. If the file Standard cabinet.top is closed, use 
Explore to select it in Windows Explorer. 
 
Once the cabinet has been selected for inclusion, the system asks for the parameters defined as drivers. 

 Enter the values for the four driver parameters. 

 

The first cabinet will be positioned as absolute coordinate system on absolute coordinate system. 

 Select Other positioning. 

 
  

Defining a parameter as a driver allows its value to be changed in an assembly that contains the component. 
In the case of this cabinet, defining the parameters as drivers allows several cabinets of different dimensions to 
be assembled using the same template. 

 
 

 
 

Note 
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 The cabinet template document opens. Select the absolute coordinate system. 

 Then select the absolute coordinate system of the assembly document as the destination coordinate system. 

 Select No propagation, then Stop so that the cabinet is not propagated. 

 >  

The component insertion function loops at the start of the cabinet inclusion in order to insert another one. 

 Enter the new dimensions for the second cabinet. 

 Once the second cabinet has been generated, click in the assembly document to release it. 

 

 Select the lower face of the second cabinet as the source geometry. 

 Select the top face of the first cabinet as the destination geometry in order to create a constraint. 

 Confirm the distance for the constraint, then place the two other constraints on the second cabinet. 

 

 Once all the constraints have been created, select Stop to proceed to the next step. 

 Then select No propagation, then Stop. 

 Continue by inserting several cabinets in order to create an assembly. 
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Exercise 10: Creation of a deck chair 

The goal of this exercise is to build the deck chair using 
certain functions that have already been covered, plus 
some new functions: 

- Creating sketches 
- Extrusions 
- Repetition on curves 
- Pipe shapes 

 

Making the parts 

Create and define the upright 

 Draw the sketch shown below. The three circle arcs are tangential. 

 

 Draw a parallel of this sketch 50mm lower down, then close the contour. The two lines that close the contour 
are perpendicular to the circle arc. 

 Extrude this sketch in the Z- direction, with an offset of 400mm and a height of 20mm. 

 Start the Wood > Define part function. 

Note: As the upright is a bent part, its cutting-up axes must be defined manually.  

 Select the support, set Select axis automatically = No, then confirm with OK. 

 

 In Length axis, select Through point. 

 Click the end points that indicate the length of the upright as shown in the next image. 
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 Select Y+ as the width axis. 

 Then set: 

- Designation: Upright 
- Material: TopSolid'Wood > Hardwoods > Larch european 

Create the blade 

 Draw the sketch opposite on the right of the upright. 

- The four segments are perpendicular. Extrude this sketch in  
Alignment = Centered mode by a height of 820mm. 

 

Repeat the blade 

 Create a new sketch, copy the three upper edges of the upright and finish the sketch. 

 Start the Curve > Extend function. 

 Select the left-hand side of the sketch as the curve to extend, then enter a length of -20mm. 

 

Note: This operation shortens the sketch by 40mm in order to repeat the blade according to this sketch. 

 Start the Repeat function, then select the first blade as the template elements to repeat. 

 Select Propagation = On curve. 

 Select the right of the sketch as the curve to propagate from the start. 

 Set: 

 

 In Number of points, enter 25. 

 Select the right-hand point of the top of the blade as the first reference point, and the left-hand point of the 
top of the blade as the second reference point. 
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Make the pockets 

 Start the Modify element function.  

 Select one of the blades in the repetition, then select Edit template. 

 

Note: A repetition is made up of three components: 

- the repetition template; 
- the propagation; 
- the copies created by the repetition (or instances). 

Editing the model allows changes to be made to the repetition template, which can then be applied to all the 
instances. 
The blades are then hidden and the repetition template is displayed. 

 Draw the sketch shown opposite by passing over the blade. 
 
 
 
 
 
 
 
 
 

 Make a pocket on the upright using Wood > Pocket.  

 Select the top face of the upright as the reference face, and the 
preceding sketches as the curve. 

 Enter a depth = 10mm with a vertical radius = 5mm. 
 
 
 
 
 
 

 Use Shape > Fillet to create a fillet with a radius of 5mm on the 
two lower edges of the blade. 

 
 

 Use Edit > Repeat > Show repetition, then select the blade 
template to display the instances of the repetition again. 

 

 Start Shape > Propagate operation. 

 

 Select the pocket on the upright as the operation to propagate. 

Note: Propagations can be performed as existing propagations to avoid having to enter new parameters. To do 
this, simply click on one of the instances of the existing repetition. 
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 Select one of the blades in the repetition as the propagation. The pocket is then propagated in the same 
manner. 

 
 

Repeat the upright 

 Start the Edit > Repeat function. 

 Select the upright as the template element to repeat. 

 Set a simple mirror with XY as the symmetry plane. 

 

Making the supports 

Draw the support 

 Create a duplicate coordinate system using Tools > Coordinate system > Duplicate coordinate system.  

Note: Duplicate coordinate systems are used to create a coordinate system from an existing coordinate system 
by performing a transformation (translation, rotation, etc.). 

 Select the document's absolute coordinate system as the coordinate system. 

 Set a transformation consisting of a translation in the Z- direction with a translation distance of 435mm. 

 Then quit and select Set as current. 
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 Draw the sketch shown below. 

- The two points are aligned with the X axis. 
- The left-hand point is aligned with the left-hand point of the upright along Y. 

 

Curving the support 

 Start the Shape > Pipe function.  

Note: The pipe shape can be used to extrude a 2D (Section curve) along a path (Guide curve). 

 Set Pipe = Tube shape to directly produce a tube following a given path. 

 

 Select the sketch as the guide curve. 

 Enter an external diameter of 30mm. 

 

 Enter a thickness of 4mm. 

The support tube is now generated. 

Repeat the support 

 Start the Named coordinate system  function, then select Absolute coordinate system. 

 

 Then repeat the support tube in Simple mirror mode with XY as the symmetry plane. 
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The history tree lets you keep track of the creation operations of elements. At any point in time it allows you 
to modify all the document's elements (shapes, parameters, etc.). 
To open the history tree, click the vertical bar between the graphics area and the context bar. 
 
 

Note 

Definition of the parts and the assembly 

 Define the tubes:  

- Designation: Tubes 
- Length axis: X+ and Width axis: Y+ 
- Untick Add to cutting-up 
- Material: TopSolid'Wood > Metals > Aluminum 
 

Note: Once the Add to cutting-up box has been unticked, remember to tick it again for parts that are cut up. 

 Define the blades: 

- Designation: Blades 
- Material: TopSolid'Wood > Hardwoods > Larch european 

As the uprights are two different parts to be produced (left and right), the two instances of the repetition must be 
defined to be able to distinguish between them. To define each instance of a repetition, you have to edit them 
one by one from the history tree. 

 
 
 
 

 
 

 
 
 
 
 
 
 
 

 
 
 

 Open the history tree. 

 Open the Main set tab. 

 Unfold the node of the repeated upright and the Results node. 
 
Note: From the history tree, a repetition is made up of three elements: 

- The template used for the repetition which is hidden. 
- A propagation that defines how the repetition is generated. 
- Results which are the template's instances produced by the propagation. 

By default, the instances are strictly identical to the template. However, they can be modified locally. 
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 Via a right-click > Characteristics on the Instance 1 line, modify the definition of the instance 1. 

- Designation: Left-hand upright 

 Then modify the instance 2: 

- Designation: Right-hand upright 

 Define the set: 

- Designation: Deck chair 
- Assembly nature: Sub-assembly 
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Exercise 11: Creation of a coffee table 

The goal of this exercise is to make a table using the notions covered during the training: 

- Creating parameters 
- Creating sketches 
- Extrusions 
- Wood operations 
- Constrained blocks 
- Drafts 
 

Creating the base 

Create the parameters 

 Create the length and width parameters of the table with the default values of 1000 x 1000. 

Create the sketch 

 Create the sketch below, including the width parameter of the table. 

- Use the Arc blend function to make the circle arcs at the base. 
- The center of the arc blends is aligned with the Y axis of the coordinate system. 

 

Extrude the base 

 Extrude this sketch by a height of 20mm. 

Saw 

 Saw the base at a distance of 35mm. 
 
Note: The tool used for sawing is a parallel sketch of a copy of the side edge. 
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Define the leg 

 Set Length axis = X+ and Width axis = Y+. 

 Enter a designation, a reference and a material. 

Repeat the leg 

 Repeat the leg in a linear manner so that the total 
space between the two legs equals the length 
parameter. 

 
 

Creating the crosspieces 

Draw the crosspieces 

 Create the sketch of the four crosspieces as shown below. 

- The section of the crosspieces is 60 x 20mm. 

 

Note: If the point of attachment of the dimension has not yet been created, a point can be created in the 
dimension function. 

 When selecting the first element to dimension, start the Point function in the system bar.  

 In this case, create a relative point.  

 Select the start point of the dimension as the position for the point. 

Extrude the crosspieces 

 Extrude the cross members in Result = One shape per curve mode between the two repeated bases. 

Make the rabbets on the crosspieces 

 Make two rabbets on the top, inside the two lower crosspieces for the glass table top. 

- Rabbet width = 15mm 
- Rabbet depth = 5mm 
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Define the crosspieces 

 Define the four cross members by entering a designation, a reference and a 
material. 

Assemble the crosspieces 

 Dowel assemble the four cross members with the two bases: 

- Step centered 
- Step = 32mm 
- Element number = 2 

 

Making the table tops 

Create the table tops 

 Create the two glass table tops on the top and the bottom as constrained blocks with a thickness = 5mm. 

- The top glass plate is attached to the upper cross members with a shift = -80mm. 
- The bottom plate is attached to the rabbets in the lower cross members. 

 

Chamfer the top table top 

 Make two 2mm chamfers on the top and bottom faces of the table tops. 

Define the parts and the set 

 Define the two table tops. 

 Define the assembly by entering a designation and a reference. This assembly is in Sub-assembly mode. 

Use the parameters 

 Use the Parameter > Edit list function to vary the dimensions of the table. 
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Creating a draft 

 Create the draft of this table in a new horizontal A3 document. 

- Main view of the assembly 
- Auxiliary view 
- Section view 
- Dimensions 
- Dimensions of the wood operations 
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